Skip Menu |
 

This queue is for tickets about the Crypt-SSLeay CPAN distribution.

Report information
The Basics
Id: 41112
Status: resolved
Priority: 0/
Queue: Crypt-SSLeay

People
Owner: Nobody in particular
Requestors: smboy85 [...] hotmail.com
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.57
Fixed in: (no value)



Subject: Installing Crypt::SSLeay 0.57 in Windows Vista Strawberry Perl
Download (untitled) / with headers
text/plain 893b
First of all thanks for the useful package. After configuring here and there, finally I got my https support ready in my strawberry perl (I think). Think I should list down what I faced to help future installers or David to patch. In order to use Crypt::SSLeay, openSSL need to be installed first. Apparently I can't get the tarball version to work correctly (Crypt::SSLeay dmake will complain missing library). The working one was another openssl for windows, which I got from some bug report thread: http://www.slproweb.com/products/Win32OpenSSL.html (not the Light version) I used 0.9.8i. After that I used cpan to install Crypt:SSLeay, dmake ok but test failed. I opened the test code and found that it was referring to some deprecated codes (Crypt::SSLeay::CTX, etc). So I did "notest install Crypt::SSleay" and the installation was successful. Now I can work with https now, happy me!
From: smboy85 [...] hotmail.com
Download (untitled) / with headers
text/plain 1.1k
Think I should include all the versions that I used too. Windows Vista Service Pack 1 Win32OpenSSL-0_9_8i.exe Crypt-SSLeay-0.57 (via CPAN) Hope that helps! On Fri Nov 21 02:12:04 2008, icecool wrote: Show quoted text
> First of all thanks for the useful package. After configuring here and > there, finally I got my https support ready in my strawberry perl (I > think). Think I should list down what I faced to help future installers > or David to patch. > > In order to use Crypt::SSLeay, openSSL need to be installed first. > Apparently I can't get the tarball version to work correctly > (Crypt::SSLeay dmake will complain missing library). The working one was > another openssl for windows, which I got from some bug report thread: > http://www.slproweb.com/products/Win32OpenSSL.html (not the Light > version) I used 0.9.8i. > > After that I used cpan to install Crypt:SSLeay, dmake ok but test > failed. I opened the test code and found that it was referring to some > deprecated codes (Crypt::SSLeay::CTX, etc). So I did "notest install > Crypt::SSleay" and the installation was successful. > > Now I can work with https now, happy me!
From: smboy85 [...] hotmail.com
Download (untitled) / with headers
text/plain 1.3k
Forgot perl version: "This is perl, v5.10.0 built for MSWin32-x86-multi-thread" Didn't say strawberry perl anywhere, hmm... but it is. On Fri Nov 21 02:14:52 2008, icecool wrote: Show quoted text
> Think I should include all the versions that I used too. > Windows Vista Service Pack 1 > Win32OpenSSL-0_9_8i.exe > Crypt-SSLeay-0.57 (via CPAN) > > Hope that helps! > > On Fri Nov 21 02:12:04 2008, icecool wrote:
> > First of all thanks for the useful package. After configuring here and > > there, finally I got my https support ready in my strawberry perl (I > > think). Think I should list down what I faced to help future installers > > or David to patch. > > > > In order to use Crypt::SSLeay, openSSL need to be installed first. > > Apparently I can't get the tarball version to work correctly > > (Crypt::SSLeay dmake will complain missing library). The working one was > > another openssl for windows, which I got from some bug report thread: > > http://www.slproweb.com/products/Win32OpenSSL.html (not the Light > > version) I used 0.9.8i. > > > > After that I used cpan to install Crypt:SSLeay, dmake ok but test > > failed. I opened the test code and found that it was referring to some > > deprecated codes (Crypt::SSLeay::CTX, etc). So I did "notest install > > Crypt::SSleay" and the installation was successful. > > > > Now I can work with https now, happy me!
>
Download (untitled) / with headers
text/plain 133b
Since Strawberry October 2009 release Crypt::SSLeay is a part of the strawberry perl distribution. So you can close this RT. -- kmx
Download (untitled) / with headers
text/plain 265b
Hello: I am closing this ticket per the following message. Thank you for your report. -- Sinan Show quoted text
> Mon Nov 23 14:52:29 2009 kmx > Since Strawberry October 2009 release Crypt::SSLeay is a part of > the strawberry perl distribution. > > So you can close this RT.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.