Skip Menu |
 

This queue is for tickets about the Mail-Builder CPAN distribution.

Report information
The Basics
Id: 40953
Status: resolved
Priority: 0/
Queue: Mail-Builder

People
Owner: Nobody in particular
Requestors: pcn60 [...] bigpond.net.au
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Makefile.PL error
Date: Sat, 15 Nov 2008 17:37:05 +1000
To: <bug-mail-builder [...] rt.cpan.org>
From: "Paul Cameron" <pcn60 [...] bigpond.net.au>
Download (untitled) / with headers
text/plain 969b
I'm trying to install Mail::Builder. When I run: perl Makefile.PL I get: [paul@Develop:/usr/local/src/Mail-Builder-1.12]sudo perl Makefile.PL Could not eval ' package ExtUtils::MakeMaker::_version; no strict; local $VERSION; $VERSION=undef; do { $VERSION = version->new("1.12"); }; $VERSION ' in lib/Mail/Builder.pm: Can't locate object method "new" via package "version" (perhaps you forgot to load "version"?) at (eval 6) line 7, <FH> line 8. Cannot determine perl version info from lib/Mail/Builder.pm Warning: prerequisite Test::Pod::Coverage 0 not found. Writing Makefile for Mail::Builder The 'version' module has been installed without any problems, and is located on the @INC path. Can you suggest how I can resolve this problem? Thanks, Paul Cameron Email: <mailto:pcn60@bigpond.net.au> pcn60@bigpond.net.au Phone: (07) 3102 5687 Mobile: 0410 442 756
Download (untitled) / with headers
text/plain 177b
I had the same problem. After updating to 'version' 0.76 the problem was gone. I guess Mail::Builder should declare that it needs at least a certain version level of 'version'.
Thank you for you bug report. The issue has been resolved in 1.13 Cheers Maroš


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.