Skip Menu |

This queue is for tickets about the Math-GSL CPAN distribution.

Report information
The Basics
Id: 40947
Status: resolved
Worked: 1 min
Priority: 0/
Queue: Math-GSL

Owner: jonathan [...]
Requestors: ANDK [...]

Bug Information
Severity: Normal
Broken in: 0.14
Fixed in: (no value)

Subject: configure_requires ExtUtils::PkgConfig
Download (untitled) / with headers
text/plain 391b
If a prerequisite must be present at configuration time (for "perl Build.PL"), the configure_requires thing should be used. This will write the dependency into META.yml such that or CPANPLUS will install it before starting the usual mantra. So you bascally only add configure_requires => { 'ExtUtils::PkgConfig' => '1.03', }, and make your users happy Thanks,
Download (untitled) / with headers
text/plain 149b
Fixed in latest bleed branch, will go into 0.16: GSL.git;a=commitdiff;h=3151492cfc1a37c454c972696ae2d207b15a24b0

This service is sponsored and maintained by Best Practical Solutions and runs on infrastructure.

Please report any issues with to