Skip Menu |
 

This queue is for tickets about the XML-LibXML CPAN distribution.

Report information
The Basics
Id: 40671
Status: resolved
Priority: 0/
Queue: XML-LibXML

People
Owner: Nobody in particular
Requestors: dmaki [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 1.67
Fixed in: (no value)



Subject: XML::LibXML 1.67 fails to compile with older? libxml2
my libxml2 is the standard for OS X 10.5.5: daisuke@beefcake-7 ~$ xml2-config --version 2.6.16 during make, I get these: LibXML.xs:113: error: syntax error before 'xmlTextReaderErrorFunc' LibXML.xs:113: warning: no semicolon at end of struct or union LibXML.xs:127: error: syntax error before 'xsdPlug' LibXML.xs:127: warning: data definition has no type or storage class LibXML.xs:145: error: syntax error before '}' token LibXML.xs: In function 'XS_XML__LibXML__parse_html_fh': LibXML.xs:2313: error: 'well_formed' undeclared (first use in this function) LibXML.xs:2313: error: (Each undeclared identifier is reported only once LibXML.xs:2313: error: for each function it appears in.) make: *** [LibXML.o] Error 1 I can confirm that the last batch is from a missing declaraion of the variable 'wel_formed', which only shows up if you have older versions of libxml2. The others happen when certain ifdefs that have to do with xmlreader and schemas. I can shut them up forcefully if I place some custom ifdefs, but am not sure if this is the intended behavior.
fixed in the SVN. Thanks.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.