Skip Menu |
 

This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id: 40574
Status: resolved
Priority: 0/
Queue: Module-Install

People
Owner: Nobody in particular
Requestors: CHORNY [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Wishlist
Broken in: 0.77
Fixed in: 0.80



Subject: should not ask about install mandatory modules under CPANPLUS
Download (untitled) / with headers
text/plain 272b
Under CPANPLUS/CPAN asking about autoinstalling mandatory modules is meaningless. Result is the same - they are installed by shell. I propose to skip this question when it does not serve any purpose. Patch is attached for review. -- Alexandr Ciornii, http://chorny.net
Subject: AutoInstall.pm.patch
--- AutoInstall.pm.dist 2008-08-08 19:55:14.000000000 +0300 +++ AutoInstall.pm 2008-10-31 21:34:24.218750000 +0200 @@ -183,6 +183,7 @@ !$SkipInstall and ( $CheckOnly + or ($mandatory and $UnderCPAN) or _prompt( qq{==> Auto-install the } . ( @required / 2 )
Modified version of this patch applied into repository. -- Alexandr Ciornii, http://chorny.net
Closed this ticket as this was fixed in 0.80. Thanks.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.