Skip Menu |
 

This queue is for tickets about the Module-Build CPAN distribution.

Report information
The Basics
Id: 40532
Status: resolved
Priority: 0/
Queue: Module-Build

People
Owner: Nobody in particular
Requestors: HINNERK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.30
Fixed in: (no value)



Subject: license versions for GPL/LGPL
Download (untitled) / with headers
text/plain 318b
What about license values 'lgpl_3' and 'gpl_3' according to Software::License? When I choose 'lgpl' for my module, the generated URL in META.yml is not accurate enough - it links to http://opensource.org/licenses/lgpl-license.php which does not tell which version of the license is used in my module. Regards Hinnerk
Download (untitled) / with headers
text/plain 337b
On Thu Oct 30 08:43:06 2008, HINNERK wrote: Show quoted text
> What about license values 'lgpl_3' and 'gpl_3' according to > Software::License?
Version 0.3 of Module::Build has 'gpl2' and 'gpl3' which fixes half your problem. (See Bug #33803.) I have attached a proposed patch in the same style as #33803 to add 'lgpl2' and 'lgpl3' licences. Allan.
Download Base.pm.patch
text/x-diff 727b
--- /usr/lib/perl5/5.10.0/Module/Build/Base.pm 2008-11-03 10:22:23.000000000 +0000 +++ Base.pm 2008-11-03 10:35:53.452046559 +0000 @@ -3351,6 +3351,8 @@ artistic => 'http://opensource.org/licenses/artistic-license.php', artistic_2 => 'http://opensource.org/licenses/artistic-license-2.0.php', lgpl => 'http://opensource.org/licenses/lgpl-license.php', + lgpl2 => 'http://opensource.org/licenses/lgpl-2.1.php', + lgpl3 => 'http://opensource.org/licenses/lgpl-3.0.html', bsd => 'http://opensource.org/licenses/bsd-license.php', gpl => 'http://opensource.org/licenses/gpl-license.php', gpl2 => 'http://opensource.org/licenses/gpl-2.0.php',
Thanks. Fixed in svn r12089.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.