Skip Menu |
 

This queue is for tickets about the WWW-Automate CPAN distribution.

Report information
The Basics
Id: 4053
Status: new
Priority: 0/
Queue: WWW-Automate

People
Owner: Nobody in particular
Requestors:
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 0.20
Fixed in: (no value)



Subject: Doesn't build on RH9
Download (untitled) / with headers
text/plain 1.4k
WWW::Automate does not build on RH9 using the CPAN shell. My system locale is set to "C". I get the following errors: Manifying blib/man3/WWW::Automate.3pm /usr/bin/make -- OK Running make test PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/embedded-WWW-Automate....Name "WWW::Automate::headers" used only once: possible typo at lib/WWW/Automate.pm line 309. t/embedded-WWW-Automate....NOK 12# Failed test (lib/WWW/Automate.pm at line 146) t/embedded-WWW-Automate....NOK 15# Failed test (lib/WWW/Automate.pm at line 150) t/embedded-WWW-Automate....NOK 16# Failed test (lib/WWW/Automate.pm at line 205) t/embedded-WWW-Automate....ok 19/0Can't call method "value" on an undefined value at lib//WWW/Automate.pm line 241. # Looks like you failed 3 tests of 19. # Looks like your test died just after 19. t/embedded-WWW-Automate....dubious Test returned status 255 (wstat 65280, 0xff00) DIED. FAILED tests 12, 15-16 Failed 3/19 tests, 84.21% okay Failed Test Stat Wstat Total Fail Failed List of Failed ------------------------------------------------------------------------------- t/embedded-WWW-Automate.t 255 65280 19 3 15.79% 12 15-16 Failed 1/1 test scripts, 0.00% okay. 3/19 subtests failed, 84.21% okay. make: *** [test_dynamic] Error 2 /usr/bin/make test -- NOT OK Running make install make test had returned bad status, won't install without force Show quoted text
cpan>


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.