Skip Menu |
 

This queue is for tickets about the Module-Build CPAN distribution.

Report information
The Basics
Id: 39229
Status: resolved
Priority: 0/
Queue: Module-Build

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.2808_03
Fixed in: (no value)



Subject: Regressions with 0.2808_03
Download (untitled) / with headers
text/plain 949b
At least the following CPAN distributions using Module::Build fail building with 0.2808_03, while everything worked OK with 0.2808 (same perl=5.10.0 and same OS=freebsd 6.1): Test-Run-0.0117 Authen-Tcpdmatch-0.07 File-SmartTail-1.0.0 txt2html-2.51 Data-HexDump-XXD-0.1.0 Lab-Instrument-1.2 Remind-Parser-0.04 IO-YAML-0.07 Module-Compile-TT-0.02 Games-LMSolve-0.8.3 The failure for these looked always the same, namely: ---------------------------------------------------------------------- Output from '/usr/local/bin/perl5.10.0 Build.PL ': Checking whether your kit is complete... Looks good Checking prerequisites... Looks good Can't determine distribution version, must supply either 'dist_version', 'dist_version_from', or 'module_name' parameter at /usr/local/src/CPAN/build/Module-Build-0.2808_03-zfyKWu/blib/lib/Module/Build/Base.pm line 978. ---------------------------------------------------------------------- Regards, Slaven
Download (untitled) / with headers
text/plain 182b
Thanks Slaven. Looks like this was due to r10222, which we've reverted. 0.2808_04 has the new reversions, I think that should work fine. That's our Golden Master candidate. -Ken


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.