Skip Menu |
 

This queue is for tickets about the CPANPLUS-Dist-Deb CPAN distribution.

Report information
The Basics
Id: 39095
Status: resolved
Priority: 0/
Queue: CPANPLUS-Dist-Deb

People
Owner: Nobody in particular
Requestors: blom [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: (no value)
Fixed in: (no value)



Subject: Multiple modules with different version numbers in one release go wrong
Download (untitled) / with headers
text/plain 492b
When we make a .deb for Test::Simple, the release will be written to cpan-libtest-simple-perl_0.80-1_all.deb (note the 0.80). The release however also contains Test::Builder::Tester, version 1.13. When then we try to create and install Test::Pod, we get a dependency error. Test::Pod requires Test::Builder::Tester version 1.02 and knows it should install cpan-libtest-simple-perl for that, but that .deb is "only" version 0.80 (which is lower than 1.02), so the dependency fails. -- B10m
On Mon Sep 08 11:21:59 2008, BLOM wrote: Show quoted text
> When we make a .deb for Test::Simple, the release will be written to > cpan-libtest-simple-perl_0.80-1_all.deb (note the 0.80). > > The release however also contains Test::Builder::Tester, version 1.13.
I've added the version numbers to the output of 'l' in the default shell for clarity: Contains: Test::Builder 0.80 Test::Builder::Module 0.80 Test::Builder::Tester 1.13 Test::Builder::Tester::Color 0.0 Test::More 0.80 Test::Simple 0.80 Show quoted text
> When then we try to create and install Test::Pod, we get a dependency > error. Test::Pod requires Test::Builder::Tester version 1.02 and knows > it should install cpan-libtest-simple-perl for that, but that .deb is > "only" version 0.80 (which is lower than 1.02), so the dependency fails.
Moving this to the cpanplus-dist-deb queue, so the logic may be fixed.
This is fixed as of 0.12 (if not earlier).


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.