Skip Menu |
 

This queue is for tickets about the DBIx-Class CPAN distribution.

Report information
The Basics
Id: 39015
Status: resolved
Priority: 0/
Queue: DBIx-Class

People
Owner: Nobody in particular
Requestors: schwigon [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 0.05007
Fixed in: 0.08012



Subject: Please remove/fix v0.05xxx due to indexer problems
Download (untitled) / with headers
text/plain 1.3k
A subtle problem: In older DBIx::Class modules the contained SQL::Translator::Parser::DBIx::Class is not hidden from the PAUSE indexer (e.g., like it is hidden in newer versions of DBIx::Class). That's especially the case with DBIx::Class 0.05007 and probably all other older versions. Now, once a DBIx::Class is installed the automatic upgrade feature of CPAN.pm mentions SQL::Translator::Parser::DBIx::Class. When you then try to upgrade that, it finds the old indexed version of DBIx::Class (0.05007, but probably also other 0.05xxx) and installs that. Therefore by just upgrading a seemingly unrelated module breaks your DBIx::Class by setting it back to a state as of 2006 (at least it's not back in the 80s, with Michael J. Fox beeing a Co-Maintainer :-)). A solution would be to either - just take away all those older versions from CPAN or - upload it again with yet another minor version jump, e.g. 0.050071 which only does that hide from indexer trick like newer versions do. You might think that it's stupid to use "upgrade" from CPAN.pm, but it happened the 3rd or 4th time now to me. And "upgrade" in CPAN.pm is only one way that makes it easier to trigger it. So IMHO it's really a real world problem. Thanks. Kind regards, Steffen -- Steffen Schwigon <ss5@renormalist.net> Dresden Perl Mongers <http://dresden-pm.org/> German Perl-Workshop <http://www.perl-workshop.de/>
Download (untitled) / with headers
text/plain 339b
Continuos application of the "hide from PAUSE" trick, will only make the problem worse. Rejecting ticket until the root cause is fixed: CPAN::Shell::upgrade: is broken, it should: look at module, determine dist module is in, get latest version of dist (and probably inform the user that its gone.moved if latest != version module was in)
Download (untitled) / with headers
text/plain 1.1k
Hi! It is my fault that I took the "upgrade" feature to describe an example scenario. It has nothing to do with "upgrade", it's also just with basic installation from cpan.org. Let me try again and please allow me to respectfully re-open the bug. A distribution DBIx-Class, v0.05 contains the packages DBIx::Class SQL::Translator::Parser::DBIx::Class The distribution DBIx-Class, v0.08 also contains the packages DBIx::Class SQL::Translator::Parser::DBIx::Class but the last one is hidden from the Indexer. In any case do I have a package "SQL::Translator::Parser::DBIx::Class" on my disk. Naturally I think it belongs to some distribution below "SQL-Translator-*". If I now install SQL::Translator::Parser::DBIx::Class then the distribution is delivered where the indexer found that package. That is DBIx-Class, Version 0.05 and I therefore install that old version of DBIx-Class. I hope I could make it more clear. The problem is simple, I'm just unable to describe it in shorter words. Thanks and kind regards, Steffen -- Steffen Schwigon <ss5@renormalist.net> Dresden Perl Mongers <http://dresden-pm.org/> Deutscher Perl-Workshop <http://www.perl-workshop.de/>
Resolved as of 0.08012


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.