Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Devel-Cover CPAN distribution.

Report information
The Basics
Id: 38781
Status: open
Priority: 0/
Queue: Devel-Cover

People
Owner: Nobody in particular
Requestors: ANDK [...] cpan.org
Cc: jkeenan [...] cpan.org
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.64
Fixed in: (no value)



Subject: Instructions on how it is expected to work under mod_perl?
Download (untitled) / with headers
text/plain 886b
The current manpage of Devel::Cover says: Devel::Cover tries to do the right thing when $MOD_PERL is set. It would be nice if this could be a bit expanded so I can know what to expect as a result. At the moment I find no results from the apache started with Devel::Cover at all. I have tried in the httpd.conf: <IfDefine PERLCOVER> <IfModule mod_perl.c> PerlPassEnv DEVEL_COVER_OPTIONS <Perl> use Devel::Cover; </Perl> </IfModule> </IfDefine> And I have started the apache in various ways, like /usr/sbin/apache-perl -DPERLCOVER /usr/sbin/apache-perl -X -DPERLCOVER DEVEL_COVER_OPTIONS='-db,/tmp/cover_db' /usr/sbin/apache-perl -DPERLCOVER I find only empty directories /cover_db and /tmp/cover_db. I have changed the permissions of these directories to 777 without success. Please consider to dedicate a few words on the correct setup. Thanks!
Download (untitled) / with headers
text/plain 574b
I too am having problems with mod_perl setup. I'm on perl5.10/mod_perl2/win32. If I put Devel::Cover right in the config file (as perl -M), it verbosely explains threads are not supported, and won't start. If I put 'use Devel::Cover' into a module (BEGIN block or not) that gets loaded via PerlModule or PerlLoadModule, or even just called from my scripts, it doesn't seem to do anything besides create an empty cover_db directory, and when you stop the server, says in the error log: Not a CODE reference. END failed--call queue aborted. ...outputting no coverage data.
Download (untitled) / with headers
text/plain 328b
On Wed Jan 28 09:13:50 2009, Kevin_Field wrote: Show quoted text
> Not a CODE reference. > END failed--call queue aborted. > > ...outputting no coverage data.
I had the same error when I ran Devel::Cover with Apache::DBI under mod_perl2. http://stackoverflow.com/questions/2277098/how-can-i-run-develcover- under-mod-perl2 -- Regards, Ivan
Download (untitled) / with headers
text/plain 366b
Unfortunately Devel::Cover is unlikely to run under threads in the near future. With regards to mod_perl I'm afraid that I don't really know any more than is in the manual and that it used to work. If I have occasion to work with mod_perl in the future I will update the docs, but hopefuly someone more familiar with such matters would be able to send a patch.
Download (untitled) / with headers
text/plain 567b
On Sun Apr 11 12:54:35 2010, PJCJ wrote: Show quoted text
> Unfortunately Devel::Cover is unlikely to run under threads in the near > future. With regards to mod_perl I'm afraid that I don't really know any > more than is in the manual and that it used to work. > > If I have occasion to work with mod_perl in the future I will update the > docs, but hopefuly someone more familiar with such matters would be able > to send a patch.
Is the current documentation with respect to mod_perl valid? http://search.cpan.org/~pjcj/Devel-Cover-1.01/lib/Devel/Cover.pm#Use_with_mod_perl


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.