This queue is for tickets about the Net-IP CPAN distribution.

Report information
The Basics
Id:
3844
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
cpan [...] bat.ru
Requestors:
essuu [...] ourshack.com
Cc:
AdminCc:

BugTracker
Severity:
Normal
Broken in:
1.20
Fixed in:
1.23



Subject: unnecessary 5.8.0 requirement ?
Hi, version 1.20 includes a use 5.008 but it seems to run fine under 5.6.1. Is there any reason why 5.8.0 should be required or could it be removed ? Regards, Simon Wilcox.
From: adrian@xemacs.org
[guest - Mon Sep 22 18:39:51 2003]:
Show quoted text
> Hi, > > version 1.20 includes a use 5.008 but it seems to run fine under > 5.6.1. > > Is there any reason why 5.8.0 should be required or could it be > removed ?
I would also like to see the 5.8.0 requirement dropped, please. Adrian
Show quoted text
> > Regards, > > Simon Wilcox.
Subject: Re: unnecessary 5.8.0 requirement ?
From: Smylers <smylers@cpan.org>
[guest - Mon Sep 22 18:39:51 2003]:
Show quoted text
> version 1.20 includes a use 5.008 but it seems to run fine under > 5.6.1.
It's only the Makefile.PL that contains this requirement; the actual module doesn't require it. When creating a new Makefile.PL the current version of Perl is put there automatically (and often wrongly), so it almost certainly wasn't intentional. Smylers


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.