Skip Menu |
 

This queue is for tickets about the URI CPAN distribution.

Report information
The Basics
Id: 38123
Status: open
Priority: 0/
Queue: URI

People
Owner: Nobody in particular
Requestors: rpv [...] nikolas.ru
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: URI::QueryParam does not sets param value to empty string
Date: Sat, 2 Aug 2008 19:01:16 +0700
To: <bug-URI [...] rt.cpan.org>
From: "Pavel V. Rochnyack" <rpv [...] nikolas.ru>
Download (untitled) / with headers
text/plain 884b
I am using URI version 1.37 and have found some issues. Command perl -e ' use URI; use URI::QueryParam; $u = URI->new("http://site.com/?foo=z&"); $u->query_param(foo => 1); $u->query_param(foo => 'a'); print $u->as_string;' returns, as expected: http://site.com/?foo=a Next test, command perl -e ' use URI; use URI::QueryParam; $u = URI->new("http://site.com/?foo=z&"); $u->query_param(foo => 1); $u->query_param(foo => undef); print $u->as_string;' returns (as expected ?): http://site.com/?foo= But command perl -e ' use URI; use URI::QueryParam; $u = URI->new("http://site.com/?foo=z&"); $u->query_param(foo => 1); $u->query_param(foo => ''); print $u->as_string; ' returns http://site.com/?foo=1 but I suppose it need to be http://site.com/?foo= -- Best regards, Pavel V. Rochnyack mailto:rpv@nikolas.ru
This relates to the discussion at #62708. https://rt.cpan.org/Ticket/Display.html?id=62708


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.