Skip Menu |
 

This queue is for tickets about the CPAN CPAN distribution.

Report information
The Basics
Id: 37641
Status: open
Priority: 0/
Queue: CPAN

People
Owner: Nobody in particular
Requestors: schmorp [...] schmorp.de
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Gtk+ declares Glib only required for building
Date: Sun, 13 Jul 2008 02:14:53 +0200
To: bug-Glib [...] rt.cpan.org
From: Marc Lehmann <schmorp [...] schmorp.de>
Download (untitled) / with headers
text/plain 708b
When install Gtk, CPAN asks: T/TS/TSCH/Glib-1.183.tar.gz is just needed temporarily during building or testing. Do you want to install it permanently? (Y/n) [yes] but this is wrong and misleading (Glib is required for Gtk even during runtime, of course). likely (I haven't looked into this) this is because its listed as build_requires, which is for modules needed only for building. -- The choice of a Deliantra, the free code+content MORPG -----==- _GNU_ http://www.deliantra.net ----==-- _ generation ---==---(_)__ __ ____ __ Marc Lehmann --==---/ / _ \/ // /\ \/ / pcg@goof.com -=====/_/_//_/\_,_/ /_/\_\
RT-Send-CC: andk [...] cpan.org
On Sat Jul 12 20:15:37 2008, schmorp@schmorp.de wrote: Show quoted text
> When install Gtk, CPAN asks: > > T/TS/TSCH/Glib-1.183.tar.gz is just needed temporarily during
building or Show quoted text
> testing. Do you want to install it permanently? (Y/n) [yes] > > but this is wrong and misleading (Glib is required for Gtk even during > runtime, of course).
Oh dear, another CPAN installation problem. :-/ Thanks for the report anyway. Show quoted text
> likely (I haven't looked into this) this is because its listed as > build_requires, which is for modules needed only for building.
Actually, it's listed in 'configure_requires' which was advertised to me as *the* way to tell CPAN.pm about Makefile.PL-time requirements. But reading the META.yml spec[1], it turns out that dependencies listed in 'configure_requires' "are not required after the distribution is installed." Andreas: Could CPAN.pm suppress this question for dependencies listed in 'configure_requires' *and* 'requires'? Or is there another, better way to handle Makefile.PL-time dependencies? [1] http://module-build.sourceforge.net/META-spec-current.html#configure_requires
CC: andk [...] cpan.org
Subject: Re: [rt.cpan.org #37641] Gtk+ declares Glib only required for building
Date: Mon, 08 Sep 2008 06:26:24 +0200
To: bug-Glib [...] rt.cpan.org
From: andreas.koenig.7os6VVqR [...] franz.ak.mind.de (Andreas J. Koenig)
Download (untitled) / with headers
text/plain 1.5k
Show quoted text
>>>>> On Sun, 07 Sep 2008 14:20:32 -0400, "Torsten Schoenfeld via RT" <bug-Glib@rt.cpan.org> said:
Show quoted text
> <URL: http://rt.cpan.org/Ticket/Display.html?id=37641 > > On Sat Jul 12 20:15:37 2008, schmorp@schmorp.de wrote:
>> When install Gtk, CPAN asks: >> >> T/TS/TSCH/Glib-1.183.tar.gz is just needed temporarily during
> building or
>> testing. Do you want to install it permanently? (Y/n) [yes] >> >> but this is wrong and misleading (Glib is required for Gtk even during >> runtime, of course).
Show quoted text
> Oh dear, another CPAN installation problem. :-/ Thanks for the report > anyway.
Same here:) Show quoted text
>> likely (I haven't looked into this) this is because its listed as >> build_requires, which is for modules needed only for building.
Show quoted text
> Actually, it's listed in 'configure_requires' which was advertised to me > as *the* way to tell CPAN.pm about Makefile.PL-time requirements. But > reading the META.yml spec[1], it turns out that dependencies listed in > 'configure_requires' "are not required after the distribution is installed."
Yes, I did not write this spec but I intended to follow it. Show quoted text
> Andreas: Could CPAN.pm suppress this question for dependencies listed in > 'configure_requires' *and* 'requires'?
Yes, this is the way it should work. If it doesn't, it may be a bug on the CPAN.pm end. Which version of CPAN.pm was used? Show quoted text
> Or is there another, better way > to handle Makefile.PL-time dependencies?
No, as far as I can see at the moment, TSCH/Gtk2-1.183.tar.gz did everything right. I haven't yet reproduced the problem. Instructions how to reproduce it welcome. -- andreas
Subject: Re: [rt.cpan.org #37641] Gtk+ declares Glib only required for building
Date: Tue, 30 Dec 2008 16:11:22 +0100
To: bug-Glib [...] rt.cpan.org
From: Torsten Schoenfeld <kaffeetisch [...] gmx.de>
Download (untitled) / with headers
text/plain 720b
(Andreas J. Koenig) via RT wrote: Show quoted text
> > Andreas: Could CPAN.pm suppress this question for dependencies listed in > > 'configure_requires' *and* 'requires'?
> > Yes, this is the way it should work. If it doesn't, it may be a bug on > the CPAN.pm end. Which version of CPAN.pm was used?
I just tried to install Gtk2 with CPAN.pm version 1.9301 and I get the described message for each prerequisite (EU::Depends, EU::PkgConfig, Glib, Cairo): T/TS/TSCH/Glib-1.200.tar.gz is just needed temporarily during building or testing. Do you want to install it permanently? (Y/n) [yes] But Gtk2 lists those prerequisites under "configure_requires" and "requires": <http://search.cpan.org/src/TSCH/Gtk2-1.202/META.yml>.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.