Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Devel-Cover CPAN distribution.

Report information
The Basics
Id: 37349
Status: resolved
Priority: 0/
Queue: Devel-Cover

People
Owner: Nobody in particular
Requestors: dmn [...] debian.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: /usr/local/* ommitted in Inc
Date: Thu, 3 Jul 2008 01:30:08 +0300
To: bug-Devel-Cover [...] rt.cpan.org
From: Damyan Ivanov <dmn [...] debian.org>
Download (untitled) / with headers
text/plain 1.1k
Hi, Below I am forwarding a bugreport[1] a Debian user has sent. [1] http://bugs.debian.org/476272 My investigation showed that this is not a proble of the build environment, but in the way @INC is managed. Attached is a patch that seems to fix the problem. All tests pass. -------------------------- It seems that Devel::Cover was not build on a system with the standard include path. line 18 of the file Deveel/Cover/Inc.pm should be our @Inc = qw( . /etc/perl /usr/lib/perl/5.8.8 /usr/lib/perl5 /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/share/perl/5.8.8 /usr/share/perl5 ); not our @Inc = qw( . /etc/perl /usr/lib/perl/5.8.8 /usr/lib/perl5 /usr/share/perl/5.8.8 /usr/share/perl5 ); As this file is automatically generated it is likely that the bug is in the build environment that was used to build the package. The solution is to rebuild the package with @INC set to the default value. This is a problem because it causes './Build testcover' etc to include files that where install with CPANPLUS etc. -------------------------- TIA, -- dam JabberID: dam@jabber.minus273.org

Message body is not shown because sender requested not to inline it.

Subject: Re: [rt.cpan.org #37349] AutoReply: /usr/local/* ommitted in Inc
Date: Thu, 3 Jul 2008 01:40:38 +0300
To: Bugs in Devel-Cover via RT <bug-Devel-Cover [...] rt.cpan.org>
From: Damyan Ivanov <dmn [...] debian.org>
Download (untitled) / with headers
text/plain 157b
Oops, the patch in the initial mail is wrong. The "-d" test should be reversed. Here's the real one. -- dam JabberID: dam@jabber.minus273.org

Message body is not shown because sender requested not to inline it.

Download (untitled) / with headers
text/plain 354b
Thanks very much for this report. I've chosen to fix this in a different way and I think f650a35 should solve the problem. If you have a chance to test it from git (https://github.com/pjcj/Devel--Cover) I'd be very grateful. I'm going to close this ticket, but if there are still problems in this area, please feel free to reopen it. Thanks again.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.