Skip Menu |
 

This queue is for tickets about the Config-IniFiles CPAN distribution.

Report information
The Basics
Id: 37044
Status: resolved
Priority: 0/
Queue: Config-IniFiles

People
Owner: SHLOMIF [...] cpan.org
Requestors: RSAVAGE [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 2.39
Fixed in: (no value)



Subject: Package 'Config::IniFiles' already declared with version '2.39'
Download (untitled) / with headers
text/plain 569b
When using Module::Build V 0.280801 and running: perl Build.PL I get: Checking prerequisites... Package 'Config::IniFiles' already declared with version '2.39', ignoring subsequent declaration. Looks good where the 2 central lines are caused by line 2 in IniFiles.pm: $Config::IniFiles::VERSION = (qw($Revision: 2.39 $))[1]; followed by line 2135: $Config::IniFiles::VERSION = $Config::IniFiles::VERSION; The solution is to change line 2 to be: $Config::IniFiles::VERSION = $Config::IniFiles::VERSION = (qw($Revision: 2.39 $))[1]; and to delete lines 2133 .. 2137.
This was fixed in the version on the CPAN, by making the VERSION a use vars variable.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.