This queue is for tickets about the Coat CPAN distribution.

Report information
The Basics
Id:
35691
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
dmn [...] debian.org
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
  • 0.1_0.2
  • 0.1_0.3
  • 0.1_0.4
  • 0.1_0.5
  • 0.1_0.6
Fixed in:
0.1



Subject: Versions with underscore confuse Version.pm
Hi, With perl 5.10, there appears to be stricter requirement about version numbers. Trying to build Coat-Persistent fails with: /usr/bin/perl Makefile.PL INSTALLDIRS=vendor Invalid version format (underscores before decimal) at /usr/share /perl/5.10/ExtUtils/MakeMaker.pm line 409. Using a dot instead of underscore should help. Thanks, dam


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.