Skip Menu |
 

This queue is for tickets about the Math-Pari CPAN distribution.

Report information
The Basics
Id: 35493
Status: open
Priority: 0/
Queue: Math-Pari

People
Owner: Nobody in particular
Requestors: paul [...] city-fan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 2.010800
Fixed in: (no value)



Subject: Where is pari-2.1.8 ?
Download (untitled) / with headers
text/plain 333b
The current release 2.010800 implies from its numbering that it's tested against pari-2.1.8, but there doesn't appear to be a release of pari 2.1.* later than 2.1.7. What am I missing? Given that pari upstream has moved on significantly from 2.1.x anyway, what is the version of pari that you would recommend to use with Math::Pari?
CC: undisclosed-recipients: ;
Subject: Re: [rt.cpan.org #35493] Where is pari-2.1.8 ?
Date: Mon, 28 Apr 2008 17:10:14 -0700
To: "paul [...] city-fan.org via RT" <bug-Math-Pari [...] rt.cpan.org>
From: Ilya Zakharevich <nospam-abuse [...] ilyaz.org>
Download (untitled) / with headers
text/plain 1.1k
On Mon, Apr 28, 2008 at 07:20:00PM -0400, paul@city-fan.org via RT wrote: Show quoted text
> > Mon Apr 28 19:19:59 2008: Request 35493 was acted upon. > Transaction: Ticket created by paul@city-fan.org > Queue: Math-Pari > Subject: Where is pari-2.1.8 ? > Broken in: 2.010800 > Severity: Normal > Owner: Nobody > Requestors: paul@city-fan.org > Status: new > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=35493 > > > > The current release 2.010800 implies from its numbering that it's tested > against pari-2.1.8, but there doesn't appear to be a release of pari > 2.1.* later than 2.1.7. What am I missing?
Just a senior moment when I choose the name for the new version: I forgot about "tested with" convention, and it came to my attention exaclty when I started the upload to PAUSE... Sorry... Show quoted text
> Given that pari upstream has moved on significantly from 2.1.x anyway, > what is the version of pari that you would recommend to use with Math::Pari?
I'm using it with 2.3.0. (One should manually check that the test failure is not worse than the expected values reported by Makefile.PL.) Hope this helps, Ilya
From: paul [...] city-fan.org
Download (untitled) / with headers
text/plain 1.1k
On Mon Apr 28 20:15:01 2008, nospam-abuse@ilyaz.org wrote: Show quoted text
> On Mon, Apr 28, 2008 at 07:20:00PM -0400, paul@city-fan.org via RT > wrote:
> > The current release 2.010800 implies from its numbering that it's
> tested
> > against pari-2.1.8, but there doesn't appear to be a release of pari > > 2.1.* later than 2.1.7. What am I missing?
> > Just a senior moment when I choose the name for the new version: I > forgot about "tested with" convention, and it came to my attention > exaclty when I started the upload to PAUSE... Sorry... >
> > Given that pari upstream has moved on significantly from 2.1.x
> anyway,
> > what is the version of pari that you would recommend to use with
> Math::Pari? > > I'm using it with 2.3.0. (One should manually check that the test > failure is not worse than the expected values reported by > Makefile.PL.) > > Hope this helps, > Ilya
Ok, thanks for the clarification. Another couple of issues come to mind though: 1. If you're using it with 2.3.0, are you going to make the next release 2.030001 to reflect that? 2. Is there some particular reason why you stick with 2.3.0 rather than say 2.3.3, the current upstream "stable" release? Paul.
CC: undisclosed-recipients: ;
Subject: Re: [rt.cpan.org #35493] Where is pari-2.1.8 ?
Date: Thu, 1 May 2008 09:14:21 -0700
To: "paul [...] city-fan.org via RT" <bug-Math-Pari [...] rt.cpan.org>
From: Ilya Zakharevich <nospam-abuse [...] ilyaz.org>
Download (untitled) / with headers
text/plain 524b
On Thu, May 01, 2008 at 08:35:20AM -0400, paul@city-fan.org via RT wrote: Show quoted text
> > I'm using it with 2.3.0. (One should manually check that the test > > failure is not worse than the expected values reported by > > Makefile.PL.)
Show quoted text
> 1. If you're using it with 2.3.0, are you going to make the next release > 2.030001 to reflect that?
Not until all the tests pass. Show quoted text
> 2. Is there some particular reason why you stick with 2.3.0 rather than > say 2.3.3, the current upstream "stable" release?
None I know of... ;-) Yours, Ilya
Download (untitled) / with headers
text/plain 1.2k
On Thu May 01 12:14:44 2008, nospam-abuse@ilyaz.org wrote: Show quoted text
> On Thu, May 01, 2008 at 08:35:20AM -0400, paul@city-fan.org via RT wrote:
> > > I'm using it with 2.3.0. (One should manually check that the test > > > failure is not worse than the expected values reported by > > > Makefile.PL.)
>
> > 1. If you're using it with 2.3.0, are you going to make the next release > > 2.030001 to reflect that?
> > Not until all the tests pass. >
> > 2. Is there some particular reason why you stick with 2.3.0 rather than > > say 2.3.3, the current upstream "stable" release?
> > None I know of... ;-)
Just tried 2.010802 with pari 2.3.4 on Fedora 11 (i586 and x86_64) and all the tests either passed or got skipped, though on x86_64 there was a slight issue: the pari test suite doesn't include expected results for 64-bit arches if they're the same as the 32-bit ones, and it copies over the expected results from the src/test/32 directory to the src/test/64 directory at build time if the results file is missing in the src/test/64 directory. The Math::Pari test suite doesn't do this and so the tests fail. Copying over the missing results manually before running the tests fixes this, so perhaps the Math::Pari test suite could do this itself in future?


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.