Skip Menu |
 

This queue is for tickets about the Algorithm-SixDegrees CPAN distribution.

Report information
The Basics
Id: 35351
Status: open
Priority: 0/
Queue: Algorithm-SixDegrees

People
Owner: Nobody in particular
Requestors: pjacklam [...] online.no
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.03
Fixed in: (no value)



Subject: Incorrect Perl version numbering
Download (untitled) / with headers
text/plain 291b
The file "Build.PL" contains the line 'perl' => '5.6', but it should use the same number format as Perl's $] variable: 'perl' => 5.006, I use Perl 5.8.8, but the $] variable is 5.008008, so when I install this module, I get the error message: requires perl '5.6'; you have only 5.008008
Download (untitled) / with headers
text/plain 145b
Almost 8 years later, this bug still exists: Checking prerequisites... requires: ! perl (5.22.1) is installed, but we need version >= 5.6
Download (untitled) / with headers
text/plain 331b
On 2016-03-18 05:57:45, pjacklam wrote: Show quoted text
> Almost 8 years later, this bug still exists: > > Checking prerequisites... > requires: > ! perl (5.22.1) is installed, but we need version >= 5.6
Interesting: Makefile.PL does not specify a perl minimum requirement. So a possible workaround is to use this one instead of Build.PL.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.