Skip Menu |
 

This queue is for tickets about the Net-Clickatell CPAN distribution.

Report information
The Basics
Id: 35249
Status: resolved
Priority: 0/
Queue: Net-Clickatell

People
Owner: MOBILEART [...] cpan.org
Requestors: perl [...] abc-rallying.co.uk
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.10
Fixed in: (no value)



Subject: UseSSL bug during initialisation
Download (untitled) / with headers
text/plain 716b
I have been looking at using your perl module Net::Clickatell 0.10. I wrote some module tests to check the functionality and I noticed a couple of bugs. In 'new' the BASE_URL is always set to https even if UseSSL is set to zero. The condition 'if (exists $args{UseSSL})' should read 'if ($args{UseSSL})'. sendSIWAPPush uses a routine 'getTime' which is not defined. sendMMNotification defines a variable $tranid which is never used. I have attached the module test file which shows the BASE_URL bug, feel free to include the tests with the module distribution if you wish. You need to have Test::MockModule installed to complete all of the tests. I am running it on Activestate perl 5.8.8 817 under windows XP.
Subject: 01netClickatell.t
Download 01netClickatell.t
text/x-perl 17.6k

Message body is not shown because it is too large.

Have made the changes. Attached is the new package.
Download Net-Clickatell-0.20.tgz
application/x-compressed 4.9k

Message body not shown because it is not plain text.

Download (untitled) / with headers
text/plain 296b
On Mon Apr 21 10:40:53 2008, MOBILEART wrote: Show quoted text
> Have made the changes. > > Attached is the new package.
Thanks for the quick response. it has been fixed when the baseUrl has been supplied (line 208) but there is still a path through the code where the bug can show up (line 200) thanks, Ian
Please test it again. Let me know whether it works. Thanks.
Subject: Re: [rt.cpan.org #35249] UseSSL bug during initialisation
Date: Tue, 22 Apr 2008 14:33:05 +0100
To: bug-Net-Clickatell [...] rt.cpan.org
From: "Ian Clark" <ian [...] abc-rallying.co.uk>
Download (untitled) / with headers
text/plain 357b
"Christopherus Goo via RT" <bug-Net-Clickatell@rt.cpan.org> wrote: Show quoted text
> > <URL: http://rt.cpan.org/Ticket/Display.html?id=35249 > > > Please test it again. Let me know whether it works. > > Thanks. > >
I have tried it against 0.20 and it still fails when UseSSL=>0, and BaseURL is not set. I have attached a small test script which shows the bug. Ian
Download use_ssl.pl
text/x-perl 2k

Message body is not shown because sender requested not to inline it.

From: MOBILEART [...] cpan.org
Download (untitled) / with headers
text/plain 665b
Sorry, I have attached the new version, some how you didn't get it. Alternatively, you can get it at: http://www.artofmobile.com/Net-Clickatell-0.21.tgz Please test it again. Let me know whether it works. Thanks. On Tue Apr 22 09:33:32 2008, ian@abc-rallying.co.uk wrote: Show quoted text
> "Christopherus Goo via RT" <bug-Net-Clickatell@rt.cpan.org> wrote: >
> > > > <URL: http://rt.cpan.org/Ticket/Display.html?id=35249 > > > > > Please test it again. Let me know whether it works. > > > > Thanks. > > > >
> > I have tried it against 0.20 and it still fails when UseSSL=>0, and > BaseURL is > not set. I have attached a small test script which shows the bug. > > Ian >
Download Net-Clickatell-0.21.tgz
application/x-compressed 5k

Message body not shown because it is not plain text.

Subject: Re: [rt.cpan.org #35249] UseSSL bug during initialisation
Date: Wed, 23 Apr 2008 08:30:27 +0100
To: bug-Net-Clickatell [...] rt.cpan.org
From: "Ian Clark" <ian [...] abc-rallying.co.uk>
Download (untitled) / with headers
text/plain 937b
Yes, that worked fine. Thanks for fixing it so quickly. Cheers, Ian "Christopherus Goo via RT" <bug-Net-Clickatell@rt.cpan.org> wrote: Show quoted text
> > <URL: http://rt.cpan.org/Ticket/Display.html?id=35249 > > > Sorry, I have attached the new version, some how you didn't get it. > Alternatively, you can get it at: > > http://www.artofmobile.com/Net-Clickatell-0.21.tgz > > Please test it again. Let me know whether it works. > > > Thanks. > > On Tue Apr 22 09:33:32 2008, ian@abc-rallying.co.uk wrote:
> > "Christopherus Goo via RT" <bug-Net-Clickatell@rt.cpan.org> wrote: > >
> > > > > > <URL: http://rt.cpan.org/Ticket/Display.html?id=35249 > > > > > > > Please test it again. Let me know whether it works. > > > > > > Thanks. > > > > > >
> > > > I have tried it against 0.20 and it still fails when UseSSL=>0, and > > BaseURL is > > not set. I have attached a small test script which shows the bug. > > > > Ian > >
> > > >
Problem resolved in version 0.2.1. A new version-- 0.3 is released.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.