Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Alien-SVN CPAN distribution.

Report information
The Basics
Id: 35205
Status: open
Priority: 0/
Queue: Alien-SVN

People
Owner: Nobody in particular
Requestors: Todd_Ross [...] mgic.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: build problem
Date: Fri, 18 Apr 2008 16:38:46 -0500
To: bug-Alien-SVN [...] rt.cpan.org
From: Todd Ross <Todd_Ross [...] mgic.com>
Download (untitled) / with headers
text/plain 31.4k

Message body is not shown because it is too large.

Subject: Re: [rt.cpan.org #35205] build problem
Date: Sat, 19 Apr 2008 06:57:47 -0700
To: bug-Alien-SVN [...] rt.cpan.org
From: Michael G Schwern <schwern [...] pobox.com>
Todd Ross via RT wrote: Show quoted text
> I'm trying to install Alien::SVN and am having problems with the Build > step. I've included the full output below. Do you see anything wrong in > the output?
cd subversion/libsvn_subr && /bin/bash /home/me/perltemp/Alien-SVN-1.4.6.0/src/subversion/libtool --tag=CC --silent --mode=link cc -g -mt -D_LARGEFILE64_SOURCE -DNE_LFS -L/usr/local/lib -rpath /usr/local/lib/perl5/site_perl/5.8.8/sun4-solaris/Alien/SVN --prefix=/usr/local -o libsvn_subr-1.la auth.lo cmdline.lo compat.lo config.lo config_auth.lo config_file.lo config_win.lo constructors.lo ctype.lo date.lo dso.lo error.lo hash.lo io.lo kitchensink.lo lock.lo md5.lo nls.lo opt.lo path.lo pool.lo prompt.lo quoprint.lo simple_providers.lo sorts.lo ssl_client_cert_providers.lo ssl_client_cert_pw_providers.lo ssl_server_trust_providers.lo stream.lo subst.lo svn_base64.lo svn_string.lo target.lo time.lo user.lo username_providers.lo utf.lo utf_validate.lo validate.lo version.lo xml.lo /usr/local/apache2/lib/libaprutil-0.la -lldap -llber -lexpat -liconv /usr/local/apache2/lib/libapr-0.la -lsendfile -lrt -lm -lsocket -lnsl -lresolv -lpthread -ldl -lsocket -lz make: *** [subversion/libsvn_subr/libsvn_subr-1.la] Error 1 libtool exited with non-zero, but oddly didn't show anything on STDERR. That's about the extent of my C debugging skills. Show quoted text
> Is there a way to have Alien::SVN use an existing libsvn* installation > instead of relying on the v1.4.6 you're distributing with the package?
It would probably be pretty easy, if you can reliably detect that all the shared libraries and header files exist. Probably just a matter of going into subversion/bindings/swig/perl/native and overriding INC and LIBS so they don't try to use the source ones. Or you can do the installation by hand following the instructions in "PROGRAMMING LANGUAGE BINDINGS" in src/subversion/INSTALL. Alien::SVN is just an attempt at mechanizing that process. -- We do what we must because we can. For the good of all of us, Except the ones who are dead. -- Jonathan Coulton, "Still Alive"


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.