Skip Menu |
 
rt.cpan.org will be shut down on March 1st, 2021.

This queue is for tickets about the Apache2-ClickPath CPAN distribution.

Report information
The Basics
Id: 34635
Status: new
Priority: 0/
Queue: Apache2-ClickPath

People
Owner: Nobody in particular
Requestors: imacat [...] mail.imacat.idv.tw
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 1.900
Fixed in: (no value)

Attachments
Apache2-ClickPath-1.900-mod_perl2.diff



Subject: Use "mod_perl2" Instead of "mod_perl" in PREREQ_PM of Makefile.PL
Download (untitled) / with headers
text/plain 1.4k
Dear Torsten Förtsch, Hi. This is imacat from Taiwan. I found that your Apache2-ClickPath-1.900 is not actually looking for mod_perl 2.x, but mod_perl 1.x. I tried to look into your Makefile.PL. It lists a virtual module "mod_perl", which is only available in mod_perl 1.x. This virtual module has changed its name to "mod_perl2" since mod_perl 2.x. Thus when you list "mod_perl" in the PREREQ_PM, it actually looks for mod_perl 1.x, but not mod_perl 2.x. You should use list "mod_perl2" instead of "mod_perl" in the PREREQ_PM of your Makefile.PL. The attached terminal log below is what I have tested on my system which has mod_perl 2.x installed. As it shows, it did not found the already-installed mod_perl 2.x and prompt me to install it, which later it actually will install mod_perl 1.x. imacat@rinse tmp/Apache2-ClickPath-1.900 % perl -mApache2::Util -e'print $Apache2::Util::VERSION;'; echo 2.000003 imacat@rinse tmp/Apache2-ClickPath-1.900 % perl Makefile.PL [ info] generating script t/TEST Checking if your kit is complete... Looks good Warning: prerequisite Crypt::Blowfish not found. Warning: prerequisite Crypt::CBC 2.14 not found. Warning: prerequisite mod_perl 1.999022 not found. Writing Makefile for Apache2::ClickPath imacat@rinse tmp/Apache2-ClickPath-1.900 % I have made a simple patch in the hope that it helps. Please tell me if you need any more information, or if I could be of any help. Thank you.
Subject: Apache2-ClickPath-1.900-mod_perl2.diff
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 diff -u -r Apache2-ClickPath-1.900.orig/Makefile.PL Apache2-ClickPath-1.900/Makefile.PL - --- Apache2-ClickPath-1.900.orig/Makefile.PL 2006-06-03 03:03:24.000000000 +0800 +++ Apache2-ClickPath-1.900/Makefile.PL 2008-04-03 02:47:44.000000000 +0800 @@ -13,7 +13,7 @@ my %require = ( "Apache::Test" => "", # any version will do - - mod_perl=>1.999022, + "mod_perl2" => 2, "LWP::UserAgent" => '', "Crypt::CBC" => '2.14', "Crypt::Blowfish" => '', -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.9 (GNU/Linux) iEYEARECAAYFAkfz1P4ACgkQi9gubzC5S1yX5gCeOnK186jIuuO+9xjs6jZT0heP ie8AniJQ3m1DwRNqwguMcgospH5nFNn7 =elF8 -----END PGP SIGNATURE-----


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.