Skip Menu |
 

This queue is for tickets about the OpenFrame-Segment-Apache2 CPAN distribution.

Report information
The Basics
Id: 34626
Status: new
Priority: 0/
Queue: OpenFrame-Segment-Apache2

People
Owner: Nobody in particular
Requestors: imacat [...] mail.imacat.idv.tw
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 1.00
Fixed in: (no value)

Attachments
OpenFrame-Segment-Apache2-1.00-mod_perl2.diff



Subject: Use "mod_perl2" Instead of "mod_perl" in PREREQ_PM of Makefile.PL
Download (untitled) / with headers
text/plain 1.5k
Dear Leon Brocard, Hi. This is imacat from Taiwan. I found that the Makefile.PL of your OpenFrame-Segment-Apache2-1.00 uses the Apache2 module, which does not exist in the current mod_perl 2.x distribution. The result is that I can not even run Makefile.PL even if mod_perl 2.x is available. The attached terminal log below shows it. imacat@rinse /tmp/OpenFrame-Segment-Apache2-1.00 % perl -mApache2::Util -e'print $Apache2::Util::VERSION;'; echo 2.000003 imacat@rinse /tmp/OpenFrame-Segment-Apache2-1.00 % perl Makefile.PL Can't locate Apache2.pm in @INC (@INC contains: /home/imacat/lib/perl5 /usr/lib/perl5/5.8.8/x86_64-linux-thread-multi-ld /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/x86_64-linux-thread-multi-ld /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/share/perl5 .) at Makefile.PL line 3. BEGIN failed--compilation aborted at Makefile.PL line 3. imacat@rinse /tmp/OpenFrame-Segment-Apache2-1.00 % Also, I found that the PREREQ_PM in the Makefile.PL of your OpenFrame-Segment-Apache2-1.00 is not actually looking for mod_perl 2.x, but mod_perl 1.x. It lists a virtual module "mod_perl", which is only available in mod_perl 1.x. This virtual module has changed its name to "mod_perl2" since mod_perl 2.x. Thus when you list "mod_perl" in PREREQ_PM, it actually looks for mod_perl 1.x, but not mod_perl 2.x. You should use "mod_perl2" instead of "mod_perl" in the PREREQ_PM of your Makefile.PL. I have made a simple patch in the hope that it helps. Please tell me if you need any more information, or if I could be of any help. Thank you.
Subject: OpenFrame-Segment-Apache2-1.00-mod_perl2.diff
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 diff -u -r OpenFrame-Segment-Apache2-1.00.orig/Makefile.PL OpenFrame-Segment-Apache2-1.00/Makefile.PL - --- OpenFrame-Segment-Apache2-1.00.orig/Makefile.PL 2002-12-19 23:19:47.000000000 +0800 +++ OpenFrame-Segment-Apache2-1.00/Makefile.PL 2008-04-03 01:47:00.000000000 +0800 @@ -1,13 +1,12 @@ use strict; use warnings; - -use Apache2; use ExtUtils::MakeMaker; WriteMakefile( NAME => "OpenFrame::Segment::Apache2", VERSION_FROM => "lib/OpenFrame/Segment/Apache2.pm", PREREQ_PM => { - - 'mod_perl' => '1.9908', + 'mod_perl2' => '2', 'OpenFrame::AppKit' => '1.00', 'LWP::UserAgent' => '2.001', 'HTTP::Cookies' => '1.25', -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.9 (GNU/Linux) iEYEARECAAYFAkfzxqcACgkQi9gubzC5S1wH3gCgk2S8BVPStePrShlUJ8bjNIg/ c4QAoI5+25yy71wIXloWWYP9pn7iliiR =wiSn -----END PGP SIGNATURE-----


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.