Skip Menu |
 

This queue is for tickets about the JSON-Any CPAN distribution.

Report information
The Basics
Id: 34469
Status: resolved
Priority: 0/
Queue: JSON-Any

People
Owner: Nobody in particular
Requestors: mutant.nz [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.16
Fixed in: (no value)



Subject: "use 5.8.3" in Makefile.PL
Download (untitled) / with headers
text/plain 406b
Hi, The Makefile.PL has "use 5.8.3", however some of us are unfortunately still stuck on Perl 5.8.0. I have installed JSON::Any using Perl 5.8.0 and it seems to run fine (I know of at least one other who has done so, as well). Is it possible to remove this dependancy? This would probably be helpful for the DBIx::Class project, since JSON::Any is the only required module that needs 5.8.3. Thanks, Sam.
Download (untitled) / with headers
text/plain 685b
Created commit ddb8a55: drop the dep down to 5.008 I've thought long and hard about this dep. On the one hand I have to draw a line somewhere on what I support 5.8.3 seemed to be the earliest non-broken 5.8.x series. However the fact is that I don't personally test on anything earlier than 5.8.8 (or anymore 5.10) so it really is still arbitrary what bugs might be affected. I've gone ahead and lowered the version number required to 5.8.0 as this will make your life easier but I reserve the right to increase it again if I have issues that I can't (easily) resolve. This is probably far more than you wanted to know but I needed to get my thoughts on the dependency out some too.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.