Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the devel-nytprof CPAN distribution.

Report information
The Basics
Id: 33991
Status: resolved
Worked: 1 min
Priority: 0/
Queue: devel-nytprof

People
Owner: akaplan [...] cpan
Requestors: DROLSKY [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in:
  • 0.02
  • 0.03
  • 0.05
  • 0.08
Fixed in: 1.10



Subject: CPAN shell will not upgrade NYTProf because of version inconsistencies
Download (untitled) / with headers
text/plain 391b
The version in the module has not changed between releases of the distribution, so CPAN will not upgrade when I tell it to "install Devel::NYTProf". Unfortunately, the only good solution for this is to make your disto version match the module version, which means making the next distro release > 1.04. You really should keep these versions the same for the benefit of the CPAN toolchain.
Download (untitled) / with headers
text/plain 572b
On Tue Mar 11 11:08:52 2008, DROLSKY wrote: Show quoted text
> The version in the module has not changed between releases of the > distribution, so CPAN will not upgrade when I tell it to "install > Devel::NYTProf". > > Unfortunately, the only good solution for this is to make your disto > version match the module version, which means making the next distro > release > 1.04. > > You really should keep these versions the same for the benefit of the > CPAN toolchain.
Thanks, I find the CPAN toolchain to by mysterious sometimes. Some things work here but not there. Anyway, will do.
Download (untitled) / with headers
text/plain 122b
0.09 is up. META.yml, Reader.pm and NYTProf.pm have VERSION=0.09, which matches the tarball version. Should be fixed now.
CC: DROLSKY [...] cpan.org
Subject: Re: [rt.cpan.org #33991] CPAN shell will not upgrade NYTProf because of version inconsistencies
Date: Wed, 19 Mar 2008 15:34:22 -0500 (CDT)
To: "Adam J. Kaplan via RT" <bug-devel-nytprof [...] rt.cpan.org>
From: Dave Rolsky <autarch [...] urth.org>
Download (untitled) / with headers
text/plain 887b
On Wed, 19 Mar 2008, Adam J. Kaplan via RT wrote: Show quoted text
> 0.09 is up. META.yml, Reader.pm and NYTProf.pm have VERSION=0.09, which > matches the tarball version. Should be fixed now.
This is still somewhat broken as far as CPAN is concerned, unfortunately. The version I have installed locally (1.04) is higher than the CPAN version (0.09), so the CPAN shell will not want to install the version you just uploaded. Anyone who installed any of your last few releases will be in the same boat. I can force install the latest release, and as long as you keep things sane then going forward it If you're dead set against making 1.05 the distro version, I, you need to delete the older versions off CPAN where the module version is Show quoted text
> 0.09. Otherwise when someone goes to "install Devel::NYTProf" from the
CPAN shell, it'll grab the 0.08 distro, where the module version is 1.04. -dave
Download (untitled) / with headers
text/plain 1.3k
On Wed Mar 19 16:34:41 2008, autarch@urth.org wrote: Show quoted text
> On Wed, 19 Mar 2008, Adam J. Kaplan via RT wrote: >
> > 0.09 is up. META.yml, Reader.pm and NYTProf.pm have VERSION=0.09, which > > matches the tarball version. Should be fixed now.
> > This is still somewhat broken as far as CPAN is concerned, unfortunately. > > The version I have installed locally (1.04) is higher than the CPAN > version (0.09), so the CPAN shell will not want to install the version > you just uploaded. Anyone who installed any of your last few releases will > be in the same boat. I can force install the latest release, and as long > as you keep things sane then going forward it > > If you're dead set against making 1.05 the distro version, I, you need to > delete the older versions off CPAN where the module version is
> > 0.09. Otherwise when someone goes to "install Devel::NYTProf" from the
> CPAN shell, it'll grab the 0.08 distro, where the module version is 1.04. > > > -dave >
Ok Dave, what I will do is make version 1.10 the next version. As you can imagine, I really really didn't want to deviate from the numbering scheme... however this problem is ridiculous and in the end nobody will care about the versions. I really don't want to see another 1.04-related XSLoader error from the CPAN testers. I really hope this fixes it and thank you for your guidance here. 1.10 will be mirrored at internet speed.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.