Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the CPAN-Reporter CPAN distribution.

Report information
The Basics
Id: 33894
Status: resolved
Priority: 0/
Queue: CPAN-Reporter

People
Owner: dagolden [...] cpan.org
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.11
Fixed in: (no value)



Subject: Failure report could be sent after "PL NA"
Download (untitled) / with headers
text/plain 381b
The attached typescript (best readable with "less -R" because of the ANSI sequences) is created using perl5.00505 -MCPAN -e 'test("Data::ResultSet")' CPAN::Reporter detects that the prerequisites are too low and a "PL NA" report is sent. But after the failed test phase, another report with a "test FAIL" would be sent, which I think should not be done. Regards, Slaven
Subject: script
Download script
application/octet-stream 9.4k

Message body not shown because it is not plain text.

Subject: Re: [rt.cpan.org #33894] Failure report could be sent after "PL NA"
Date: Wed, 19 Mar 2008 05:46:30 -0400
To: bug-CPAN-Reporter [...] rt.cpan.org
From: "David Golden" <dagolden [...] cpan.org>
Download (untitled) / with headers
text/plain 582b
On Fri, Mar 7, 2008 at 7:14 PM, Slaven_Rezic via RT <bug-CPAN-Reporter@rt.cpan.org> wrote: Show quoted text
> CPAN::Reporter detects that the prerequisites are too low and a "PL NA" > report is sent. But after the failed test phase, another report with a > "test FAIL" would be sent, which I think should not be done.
What version of CPAN.pm? And were you running under force or anything like that? (E.g. the "report" triggers a "force test"). If the grade is NA, CPAN::Reporter should be returning a failure value to CPAN.pm and that should stop it from continuing past the PL stage. David
Download (untitled) / with headers
text/plain 871b
On Wed Mar 19 05:47:29 2008, DAGOLDEN wrote: Show quoted text
> On Fri, Mar 7, 2008 at 7:14 PM, Slaven_Rezic via RT > <bug-CPAN-Reporter@rt.cpan.org> wrote:
> > CPAN::Reporter detects that the prerequisites are too low and a "PL NA" > > report is sent. But after the failed test phase, another report with a > > "test FAIL" would be sent, which I think should not be done.
> > What version of CPAN.pm? And were you running under force or anything > like that? (E.g. the "report" triggers a "force test"). > > If the grade is NA, CPAN::Reporter should be returning a failure value > to CPAN.pm and that should stop it from continuing past the PL stage. >
I could reproduce it again with BigIP-ParseConfig. The toolchain versions are: perl 5.005_05 CPAN 1.9205 CPAN::Reporter 1.13 I think I should try it again with the CPAN.pm from subversion. Regards, Slaven
I think this has been fixed in recent versions.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.