Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the XML-Atom CPAN distribution.

Report information
The Basics
Id:
33828
Status:
new
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
tim [...] bellinghausen.org
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
0.28
Fixed in:
(no value)



Subject: make test fails on Mac OS X 10.5.2
When I was trying to install XML::Atom, the make test step fails, with the following three subtests failing: t/02-content............. # Failed test in t/02-content.t at line 57. # got: 'My name is &#x5BAE;&#x5DDD;.' # expected: 'My name is 宮川.' t/11-entry............... # Failed test in t/11-entry.t at line 162. # got: '<p>&#x65E5;&#x672C;&#x8A9E;&#x306E;&#x30D5;&#x30A3;&#x30FC;&#x30C9;</p>' # expected: '<p>日本語のフィード</p>' t/18-unicode............. # Failed test in t/18-unicode.t at line 34. Wide character in print at /System/Library/Perl/5.8.8/Test/Builder.pm line 1199. # got: '<p>&#x3053;&#x308C;&#x306F;&#x65E5;&#x672C;&#x8A9E;&#x306E;&#x30DD;&#x30B9; &#x30C8;&#x3067;&#x3059;&#x3002;</p>' # expected: '<p>これは日本語のポストです。</p>' Maybe the problem is related to the different possibilities du mask Unicode charkters in XML? I use perl, v5.8.8 built for darwin-thread-multi-2level on Mac OS X 10.5.2 Build 9C31. This seem to be a rather general problem, with Mac OS X, if you have a look at the tester statistics on: <http://cpantesters.perl.org/show/XML-Atom.html>


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.