Skip Menu |
 

This queue is for tickets about the XML-Rules CPAN distribution.

Report information
The Basics
Id: 33607
Status: resolved
Priority: 0/
Queue: XML-Rules

People
Owner: JENDA [...] cpan.org
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.00
Fixed in: (no value)



Subject: Cannot install with CPAN.pm (perl version error?)
Download (untitled) / with headers
text/plain 947b
If I try to install XML::Rules with CPAN.pm using perl 5.8.8, the following error occurs: # running Build.PL /usr/local/bin/perl Build.PL Checking whether your kit is complete... Looks good Checking prerequisites... Looks good Deleting Build Removed previous script 'Build' Creating new 'Build' script for 'XML-Rules' version '1.00' (/usr/local/bin/perl Makefile.PL exited with 0) CPAN::Reporter: Makefile.PL result is 'pass', No errors. JENDA/XML-Rules-1.00.tar.gz requires perl '5.8'; you have only 5.008008; giving up JENDA/XML-Rules-1.00.tar.gz [prereq] -- NOT OK Running make test Can't test without successful make Failed during this command: JENDA/XML-Rules-1.00.tar.gz : make NO requires perl '5.8' I think this is due specifying the minimum perl version in Build.PL as '5.8', but it should be either '5.8.0' or (maybe better, because of compatibility with older perl versions) '5.008'. Regards, Slaven
I just uploaded 1.01 of XML::Rules with this fixed. Thanks!


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.