Skip Menu |
 

This queue is for tickets about the Module-CPANTS-Analyse CPAN distribution.

Report information
The Basics
Id: 32777
Status: resolved
Priority: 0/
Queue: Module-CPANTS-Analyse

People
Owner: domm [...] cpan.org
Requestors: cjm [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.75
Fixed in: (no value)



Subject: Module::Build subclass fails prereq_matches_use
Download (untitled) / with headers
text/plain 601b
I usually use a Module::Build subclass (named My_Build) to install my modules. Unfortunately, CPANTS seems to think that My_Build.pm gets installed. Therefore, it complains that Module::Build is not listed in 'requires' (it is listed in 'build_requires'). For example, http://cpants.perl.org/dist/errors/PostScript-Calendar shows "Undefined prereqs: Module-Build". (Even worse, Text::Wrapper is also listed as failing prereq_matches_use, but http://cpants.perl.org/dist/errors/Text-Wrapper shows no errors in prereq. I'm assuming that's also failing because of My_Build, but I don't really know.)
Download (untitled) / with headers
text/plain 226b
Hi! Thanks for the feedback. I looked into your problem, and the only way I can think of fixing this problem is by getting CPANTS to honor the META.yml 'no_index' key. Which you set. I've added this issue to my TODO list...
fixed in 0.82


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.