Skip Menu |
 

This queue is for tickets about the Test-Class CPAN distribution.

Report information
The Basics
Id: 32158
Status: resolved
Priority: 0/
Queue: Test-Class

People
Owner: Nobody in particular
Requestors: GWOLF [...] cpan.org
Cc: 459738 [...] bugs.debian.org
control [...] bugs.debian.org
AdminCc:

Bug Information
Severity: Normal
Broken in:
  • 0.26
  • 0.27
Fixed in: (no value)

Attachments
libtest-class-perl_0.27-1_amd64.build



CC: 459738 [...] bugs.debian.org, control [...] bugs.debian.org
Subject: Over-zealous prerequisites?
Download (untitled) / with headers
text/plain 1.7k
severity 459738 minor found 459738 0.26-1 notfound 459738 0.27-1 tags 459738 + upstream thanks (the first lines are directed to Debian's bug tracking system, please disregard them) I am one of the maintainers for your module in Debian. Your module declares the following dependency information (from META.yml): requires: Attribute::Handlers: 0.77 Class::ISA: 0.32 Devel::Symdump: 2.03 IO::File: 1.14 Storable: 2.04 Test::Builder: 0.7 Test::Builder::Tester: 1.07 Test::Exception: 0.25 Test::More: 0.7 Test::Simple: 0.7 perl: 5.6.1 Now, several of the required modules are at a higher version than what's currently available in Debian, so the module _does_ build - please refer to the attached build log, specially at: Checking prerequisites... - ERROR: Test::More (0.62) is installed, but we need version >= 0.7 - ERROR: IO::File (1.13) is installed, but we need version >= 1.14 - ERROR: Test::Builder (0.32) is installed, but we need version >= 0.7 - ERROR: Test::Simple (0.62) is installed, but we need version >= 0.7 - ERROR: Test::Builder::Tester (1.02) is installed, but we need version Show quoted text
>= 1.07
_But_ ./Build test _does_ pass all of the tests - so I guess the prerequisites are based on what you currently have in your system. It strikes me, though, that ./Build.PL complains - but does not return failure! (our package building system is essentialy based on a Makefile, so it should abort the build if such an error happens) I guess this last comment should be directed at the Module::Build maintainers, anyway... Ok, so - Hynek (the original bug submitter): I just uploaded 0.27-1, which is no longer empty (something went wrong in the 0.26 build, sorry); please check again to see if this bug still present - or if it can be closed.
Subject: libtest-class-perl_0.27-1_amd64.build
Download libtest-class-perl_0.27-1_amd64.build
application/octet-stream 8.2k

Message body not shown because it is not plain text.

Download (untitled) / with headers
text/plain 1.2k
On Tue Jan 08 11:40:50 2008, GWOLF wrote: [snip] Show quoted text
> I am one of the maintainers for your module in Debian. Your module > declares the following dependency information (from META.yml):
[snip] And a big thank you to yourself and your co-maintainers... Show quoted text
> Checking prerequisites... > - ERROR: Test::More (0.62) is installed, but we need version >= 0.7 > - ERROR: IO::File (1.13) is installed, but we need version >= 1.14 > - ERROR: Test::Builder (0.32) is installed, but we need version >= 0.7 > - ERROR: Test::Simple (0.62) is installed, but we need version >= 0.7 > - ERROR: Test::Builder::Tester (1.02) is installed, but we need version
> >= 1.07
> > _But_ ./Build test _does_ pass all of the tests - so I guess the > prerequisites are based on what you currently have in your system.
Dependencies downgraded in 0.28 - winging its way to CPAN now. Show quoted text
> It strikes me, though, that ./Build.PL complains - but does not return > failure! (our package building system is essentialy based on a Makefile, > so it should abort the build if such an error happens) I guess this last > comment should be directed at the Module::Build maintainers, anyway...
Yup. I'm pretty sure that it's intentional behaviour. Feel free to check with Ken et al. Cheers, Adrian


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.