Skip Menu |
 

This queue is for tickets about the Test-Harness CPAN distribution.

Report information
The Basics
Id: 31731
Status: resolved
Worked: 10 min
Priority: 0/
Queue: Test-Harness

People
Owner: andy [...] hexten.net
Requestors: l.mai [...] web.de
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: unicode test fails if PERL_UNICODE is set
Date: Wed, 19 Dec 2007 23:28:29 +0100
To: bug-Test-Harness [...] rt.cpan.org
From: Lukas Mai <l.mai [...] web.de>
Download (untitled) / with headers
text/plain 853b
Hi! t/unicode.........................1/? # Failed test 'Unicode smiley (script): value for description matches' # at t/unicode.t line 115. # got: 'Everything is fine âº' # expected: 'Everything is fine âº' # Looks like you failed 1 test of 20. t/unicode......................... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/20 subtests This happens if $ENV{PERL_UNICODE} contains "S" during make test. This means I can't install Bundle::CPAN from within cpan (PERL_UNICODE is set in my shell startup files). Workaround: Do a manual install, temporarily unsetting PERL_UNICODE. Exact module version: Test-Harness-3.05 perl -v: This is perl, v5.10.0 built for i686-linux uname -a: Linux nora 2.6.22-gentoo-r9 #3 PREEMPT Sat Nov 3 22:12:09 CET 2007 i686 AMD Athlon(tm) 64 Processor 3200+ AuthenticAMD GNU/Linux
Download (untitled) / with headers
text/plain 110b
Thanks Lukas. I've made t/unicode.t skip if PERL_UNICODE is set. Test::Harness 3.06 will incorporate the fix.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.