Skip Menu |
 

This queue is for tickets about the DBD-SQLite CPAN distribution.

Report information
The Basics
Id: 316
Status: resolved
Priority: 0/
Queue: DBD-SQLite

People
Owner: Nobody in particular
Requestors: pmccann [...] maths.adelaide.edu.au
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 0.09
Fixed in: 0.05



Subject: multiple definitions of symbol causes all tests to fail in .10
Download (untitled) / with headers
text/plain 840b
Hi Matt, DBD-SQLite-0.10 --not yet listed in the RT form that I'm using-- fails all tests for MacOSX 10.1.3 (that is, for Darwin 5.3) with simple variations of the following error: t/01logon..........dyld: /usr/bin/perl multiple definitions of symbol _PL_na /System/Library/Perl/darwin/CORE/libperl.dylib(globals.o) definition of _PL_na blib/arch/auto/DBD/SQLite/SQLite.bundle definition of _PL_na All tests passed fine in DBD-SQLite-0.05, which is the last version that I built and installed. Standard details follow: % perl -v This is perl, v5.6.0 built for darwin % uname -a Darwin localhost 5.3 Darwin Kernel Version 5.3: Thu Jan 24 22:06:02 PST 2002; root:xnu/xnu-201.19.obj~1/RELEASE_PPC Power Macintosh powerpc Please let me know if there's anything I can do to help track it down further or test out a fix. Cheers, Paul
Date: Thu, 28 Feb 2002 16:41:04 +0000 (GMT)
From: Matt Sergeant <matt [...] sergeant.org>
To: Guest via RT <bug-DBD-SQLite [...] rt.cpan.org>
Subject: Re: [cpan #316] multiple definitions of symbol causes all tests to fail in .10
Download (untitled) / with headers
text/plain 1.2k
Why is it always Darwin that has these stupid build errors?!? Just remove the PL_na definition lines in dbdimp.c, and it'll all be fine. On Thu, 28 Feb 2002, Guest via RT wrote: Show quoted text
> > > This message about DBD-SQLite was sent to you by guest via rt.cpan.org > > Full context and any attached attachments can be found at: > <URL: https://rt.cpan.org/Ticket/Display.html?id=316 > > > Hi Matt, > > DBD-SQLite-0.10 --not yet listed in the RT form that I'm using-- fails all tests for MacOSX 10.1.3 (that is, for Darwin 5.3) with simple variations of the following error: > > t/01logon..........dyld: /usr/bin/perl multiple definitions of symbol _PL_na > /System/Library/Perl/darwin/CORE/libperl.dylib(globals.o) definition of _PL_na > blib/arch/auto/DBD/SQLite/SQLite.bundle definition of _PL_na > > All tests passed fine in DBD-SQLite-0.05, which is the last version that I built and installed. Standard details follow: > > % perl -v > > This is perl, v5.6.0 built for darwin > > % uname -a > Darwin localhost 5.3 Darwin Kernel Version 5.3: Thu Jan 24 22:06:02 PST 2002; root:xnu/xnu-201.19.obj~1/RELEASE_PPC Power Macintosh powerpc > > Please let me know if there's anything I can do to help track it down further or test out a fix. > > Cheers, > Paul > >
-- <!-- Matt --> <:->Get a smart net</:->
From: pmccann [...] maths.adelaide.edu.au
Download (untitled) / with headers
text/plain 514b
[matt@sergeant.org - Thu Feb 28 11:41:03 2002]: Show quoted text
> Why is it always Darwin that has these stupid build errors?!?
No idea, but it must have something to do with evolution. This one does seem particularly brain-dead (having just read --and exterminated-- that particularly innocuous looking ifndef you mention below). Show quoted text
> Just remove the PL_na definition lines in dbdimp.c, and it'll all
be Show quoted text
> fine.
And indeed it was: and the DBD-SQLite world was good. Thanks a lot for the swift and incisive response, Paul
Closing bug.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.