Skip Menu |
 

This queue is for tickets about the Device-Gsm CPAN distribution.

Report information
The Basics
Id: 31540
Status: open
Worked: 1 hour (60 min)
Priority: 0/
Queue: Device-Gsm

People
Owner: cosimo [...] cpan.org
Requestors: n [...] shaplov.ru
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: $gsm->manufacturer() do not properly work for Motorola phone
Download (untitled) / with headers
text/plain 842b
$gsm->manufacturer() returns empty value for my motorola phone. This is caused because $gsm->test_command do not properly work for +CGMI command: Motorola return ERROR, when I trying to send AT+CGMI=? command, meanwhile AT+CGMI works well. So the manufacturer function should be something like this: sub manufacturer() { my $self = shift; my($ok, $man); $self->atsend( 'AT+CGMI' . Device::Modem::CR ); ($ok, $man) = $self->parse_answer($Device::Modem::STD_RESPONSE); return undef if $ok ne 'OK'; if ($man =~ /\+CGMI\:\ \"(.*)\"/s ) # Parse result of motorolla phones: +CGMI: "Motorola CE, Copyright 2004" { $man = $1; } $self->log->write('info', 'manufacturer of this device appears to be ['.$man.']'); return $man || $ok } Niolay Shaplov.
Download (untitled) / with headers
text/plain 322b
Hello, Niolay (Nicolay?) Thanks for your bug report. I've been quite busy lately, so I'm sorry to answer so late. I have changed the manufacturer function as you suggested. I have some more changes pending (also 1 more from you), then I will release the next version of Device::Gsm. Thank you very much and stay tuned.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.