This queue is for tickets about the ExtUtils-Install CPAN distribution.

Report information
The Basics
Id:
31248
Status:
resolved
Priority:
Low/Low

People
Owner:
yves [...] cpan.org
Requestors:
mschwern [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Normal
Broken in:
(no value)
Fixed in:
(no value)



Subject: Minimum version is 5.6.0
Just got a CPAN testers report from someone using 5.5.5. Seems we have some 5.6isms, the first of which it hit is "open my $fh". The minimum perl version should be bumped up to 5.6.0. This is just a BEGIN { require 5.006 } in the Makefile.PL.
And the patch. This also uses the more compatible "BEGIN { require }" syntax. Possibly overly conservative, "use X.YYY" was introduced in 5.4.0. --- Makefile.PL (revision 41129) +++ Makefile.PL (local) @@ -1,4 +1,4 @@ -use 5.00503; +BEGIN { require 5.006; } use strict; use lib qw(lib); # use ourself if possible not the existing stuff.
Ping?
closed in 1.46 -- thanks for the patch


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.