Skip Menu |
 

This queue is for tickets about the IO-Zlib CPAN distribution.

Report information
The Basics
Id: 31247
Status: open
Priority: 0/
Queue: IO-Zlib

People
Owner: Nobody in particular
Requestors: adamk [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.08
Fixed in: (no value)



Subject: Correct dependencies
Download (untitled) / with headers
text/plain 306b
IO::Zlib is known to not be supported on 5.005, and it also appears to have a dependency on Compress::Zlib that is newer than 1.42... SO! Changes to the Makefile.PL as follows. Compress::Zlib dependency to 2.007. Perl dependency to 5.006, which is to say... use 5.006; at the top of the Makefile.PL.
From: tom [...] compton.nu
Download (untitled) / with headers
text/plain 1013b
On Wed Dec 05 20:36:51 2007, ADAMK wrote: Show quoted text
> IO::Zlib is known to not be supported on 5.005, and it also appears to > have a dependency on Compress::Zlib that is newer than 1.42...
Actually it has a dependency on a Compress::Zlib with a working eof method - it appears that 1.xx versions do not have that. Show quoted text
> Changes to the Makefile.PL as follows. > > Compress::Zlib dependency to 2.007.
I'll think about this, but I'm reluctant as 1.xx is obviously still fairly common and it does (largely) work with 1.xx releases. The 1.xx releases are also much easier to install by hand, being only a single archive, so I myself often wind up installing them in order to rescue CPAN after it's been broken by a vendor perl update. Show quoted text
> Perl dependency to 5.006, which is to say... > > use 5.006; at the top of the Makefile.PL.
The dependency was changed to 5.006 in the 1.08 release. That is in Zlib.pm as it always has been - the Makefile.PL will run quite happily with earlier versions of perl as far as I know. Tom


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.