Skip Menu |
 

This queue is for tickets about the SQL-Translator CPAN distribution.

Report information
The Basics
Id: 31214
Status: new
Priority: 0/
Queue: SQL-Translator

People
Owner: Nobody in particular
Requestors: hsinclair [...] hastek.net
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: sqlt-diff option --mysql_parser_version wrong in help text
Date: Tue, 4 Dec 2007 23:07:26 -0500
To: bug-SQL-Translator [...] rt.cpan.org
From: Harold Sinclair <hsinclair [...] hastek.net>
Download (untitled) / with headers
text/plain 522b
In v0.08001, sqlt-diff lists the option --mysql_parser_version while the argument parser is looking for --mysql-parser-version While not really a but, the documentation could also use clarification about which arguments "--mysql-parser-version" will actually accept, for example --mysql-parser-version=5 works, but --mysql-parser-version=5.0.22 throws an error: Argument "5.0.22" isn't numeric in numeric gt (>) at /usr/lib/perl5/site_perl/5.8.8/SQL/Translator/Parser/MySQL.pm line 776. -- Harold Sinclair


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.