Skip Menu |
 

This queue is for tickets about the MIME-tools CPAN distribution.

Report information
The Basics
Id: 30927
Status: resolved
Priority: 0/
Queue: MIME-tools

People
Owner: Nobody in particular
Requestors: ANDK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 5.425
Fixed in: (no value)



Subject: 5.6.2 fails multiple tests
Download (untitled) / with headers
text/plain 437b
t/Smtpsend.t hangs with perl 5.6.2. This is unfortunate because so many tests fail up to this point that it is already clear that 5.6.2 is not supported and a hanging test is always a bit annoying. Please put a 'require 5.8.0' (or equivalent) into your Makefile.PL to signal the user in time that the software is not available for his 5.6. Alternatively, the dependency on 5.8 is probably fixable, but I did not look into it. Thanks,
Subject: Re: [rt.cpan.org #30927] 5.6.2 fails multiple tests
Date: Fri, 23 Nov 2007 10:20:47 -0500
To: bug-MIME-tools [...] rt.cpan.org
From: "David F. Skoll" <dfs [...] roaringpenguin.com>
Download (untitled) / with headers
text/plain 638b
Hi, Andreas, Show quoted text
> Please put a 'require 5.8.0' (or equivalent) into your Makefile.PL to > signal the user in time that the software is not available for his 5.6.
Thanks for the note. We will definitely do that. Show quoted text
> Alternatively, the dependency on 5.8 is probably fixable, but I did not > look into it.
Actually, we made a deliberate decision to abandon pre-5.8 Perl releases. The old code used IO::Stringy which is a large and messy module. The new code uses Perl 5.8's in-memory I/O facilities instead. (There is still one stubborn dependency on IO::Stringy that we have not yet removed, but we plan to eventually.) Regards, David.
MIME-tools now requires 5.8


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.