Skip Menu |
 

This queue is for tickets about the CPANPLUS-Dist-Deb CPAN distribution.

Report information
The Basics
Id: 30866
Status: resolved
Priority: 0/
Queue: CPANPLUS-Dist-Deb

People
Owner: Nobody in particular
Requestors: nom [...] standen.id.au
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.10
Fixed in: 0.10



Subject: dependency incorrect for Test::Pod
Download (untitled) / with headers
text/plain 440b
When building Test::Pod using cpanp (with CPANPLUS::Dist::Deb), the following error was encountered: cpan-libtest-pod-perl depends on libtest-simple-perl (>= 1.02) | cpan-libtest-simple-perl (>= 1.02); however: Version of libtest-simple-perl on system is 0.62-1. Package cpan-libtest-simple-perl is not installed. The requirement in Test::Pod is actually on Test::Builder::Tester 1.02, which is a module packaged inside Test::Simple.
Download (untitled) / with headers
text/plain 120b
I can't reproduce this with the current version (0.12) -- I get a dependency on libtest-simple (>= 0.88), as is correct.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.