Skip Menu |
 

This queue is for tickets about the IO-Socket-SSL CPAN distribution.

Report information
The Basics
Id: 30600
Status: resolved
Priority: 0/
Queue: IO-Socket-SSL

People
Owner: Nobody in particular
Requestors: apu_islam [...] yahoo.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Version conflict with Net::SSLeay
Date: Thu, 8 Nov 2007 20:25:21 -0800 (PST)
To: bug-IO-Socket-SSL [...] rt.cpan.org
From: Apu islam <apu_islam [...] yahoo.com>
Download (untitled) / with headers
text/plain 460b
I have installed the current version of your IO::Socket::SSL on my windows platform and found that it does not work with the current Net::SSLeay that I have. I get the following error: 'Your vendor has not defined SSLEay macro randomize at ......./ / /SSL.pm line 69." It requires the Net::SSLeay version 1.21 which is not available for download on CPAN (starts from 1.30). any suggestions ? ------------------------------ Apu Islam ( E Pluribus Unum)
Download (untitled) / with headers
text/plain 900b
Please try a simple perl -MIO::Socket::SSL -e '' Because Net::SSLeay::randomize is called at the intialization it should croak already here. If it doesn't the problem is elsewhere. If you are using PAR or compile it as an executable you might look at this thread: http://www.perlmonks.org/index.pl?displaytype=print;node_id=633340;replies=1 On Do. 08. Nov. 2007, 23:25:41, apu_islam@yahoo.com wrote: Show quoted text
> I have installed the current version of your IO::Socket::SSL on my > windows platform and found that it does not work with the current > Net::SSLeay that I have. > I get the following error: > > 'Your vendor has not defined SSLEay macro randomize at ......./ / > /SSL.pm line 69." > > It requires the Net::SSLeay version 1.21 which is not available for > download on CPAN (starts from 1.30). > any suggestions ? > > > ------------------------------ > Apu Islam > ( E Pluribus Unum) > >
Subject: Re: [rt.cpan.org #30600] Version conflict with Net::SSLeay
Date: Fri, 9 Nov 2007 16:43:07 -0800 (PST)
To: bug-IO-Socket-SSL [...] rt.cpan.org
From: Apu islam <apu_islam [...] yahoo.com>
Download (untitled) / with headers
text/plain 1.8k
This is not related to my previous question. I am trying to run a SSL forking HTTP server with Net-HTTPserver to marshall some SOAP requests. I have it working under unix, but not been able to get it running on Windows. Net-HTTPServer uses Net::SSLeay and IO::Socket::SSL. Under single server mode, IO::Socket::SSL works but on forking, it gives me the following error: Can't call method "accept" on unblessed reference at c/perl/......./Net/HTTPServer.pm line 1987 How can I make this work under windows with forking? any suggestions ? BTW, are you the same person who wrote PFSense ? ------------------------------ Apu Islam ( E Pluribus Unum) Show quoted text
----- Original Message ---- From: Steffen Ullrich via RT <bug-IO-Socket-SSL@rt.cpan.org> To: apu_islam@yahoo.com Cc: behroozi@www.pls.uni.edu Sent: Friday, November 9, 2007 1:19:40 AM Subject: [rt.cpan.org #30600] Version conflict with Net::SSLeay <URL: http://rt.cpan.org/Ticket/Display.html?id=30600 > Please try a simple perl -MIO::Socket::SSL -e '' Because Net::SSLeay::randomize is called at the intialization it should croak already here. If it doesn't the problem is elsewhere. If you are using PAR or compile it as an executable you might look at this thread: http://www.perlmonks.org/index.pl?displaytype=print;node_id=633340;replies=1 On Do. 08. Nov. 2007, 23:25:41, apu_islam@yahoo.com wrote:
> I have installed the current version of your IO::Socket::SSL on my > windows platform and found that it does not work with the current > Net::SSLeay that I have. > I get the following error: > > 'Your vendor has not defined SSLEay macro randomize at ......./ / > /SSL.pm line 69." > > It requires the Net::SSLeay version 1.21 which is not available for > download on CPAN (starts from 1.30). > any suggestions ? > > > ------------------------------ > Apu Islam > ( E Pluribus Unum) > >
Download (untitled) / with headers
text/plain 987b
On Fr. 09. Nov. 2007, 19:43:40, apu_islam@yahoo.com wrote: Show quoted text
> This is not related to my previous question. > I am trying to run a SSL forking HTTP server with Net-HTTPserver to > marshall some SOAP requests. I have it working under unix, but not > been able to get it running on Windows. Net-HTTPServer uses > Net::SSLeay and IO::Socket::SSL. Under single server mode, > IO::Socket::SSL works but on forking, it gives me the following > error: > > Can't call method "accept" on unblessed reference at > c/perl/......./Net/HTTPServer.pm line 1987 > > How can I make this work under windows with forking? any suggestions ?
could you please make a small example program which shows the problem? I'm not familiar with Net::HTTPServer so I need to know how you use it to recreate the problem myself. BTW, is the original problem from the bug resolved? Show quoted text
> BTW, are you the same person who wrote PFSense ?
No, I'm not. Ullrich is at least in Germany a very common name.
CC: behroozi [...] www.pls.uni.edu
Subject: Re: [rt.cpan.org #30600] Version conflict with Net::SSLeay
Date: Sun, 11 Nov 2007 20:52:25 -0800 (PST)
To: bug-IO-Socket-SSL [...] rt.cpan.org
From: Apu islam <apu_islam [...] yahoo.com>
Download (untitled) / with headers
text/plain 1.7k
Ok, here is the code I tried. Couple of the things are missing - namely the security certificates. I have tried with snake oil ca signed certs and it works for a single server mode ( leading me to believe the certificates work). Others are the I have changed the soap server domain names etc.. BTW. I actually know of 3 Steffen Ulrich's myself - leads me to believe this certainly is a very popular German name.. ------------------------------ Apu Islam ( E Pluribus Unum) Show quoted text
----- Original Message ---- From: Steffen Ullrich via RT <bug-IO-Socket-SSL@rt.cpan.org> To: apu_islam@yahoo.com Cc: behroozi@www.pls.uni.edu Sent: Sunday, November 11, 2007 1:26:37 PM Subject: [rt.cpan.org #30600] Version conflict with Net::SSLeay <URL: http://rt.cpan.org/Ticket/Display.html?id=30600 > On Fr. 09. Nov. 2007, 19:43:40, apu_islam@yahoo.com wrote:
> This is not related to my previous question. > I am trying to run a SSL forking HTTP server with Net-HTTPserver to > marshall some SOAP requests. I have it working under unix, but not > been able to get it running on Windows. Net-HTTPServer uses > Net::SSLeay and IO::Socket::SSL. Under single server mode, > IO::Socket::SSL works but on forking, it gives me the following > error: > > Can't call method "accept" on unblessed reference at > c/perl/......./Net/HTTPServer.pm line 1987 > > How can I make this work under windows with forking? any suggestions
? could you please make a small example program which shows the problem? I'm not familiar with Net::HTTPServer so I need to know how you use it to recreate the problem myself. BTW, is the original problem from the bug resolved?
> BTW, are you the same person who wrote PFSense ?
No, I'm not. Ullrich is at least in Germany a very common name.
Download (untitled)
"net_httpserver_soap.zip" 2.5k

Message body not shown because it is not plain text.

Subject: Re: [rt.cpan.org #30600] Version conflict with Net::SSLeay
Date: Thu, 15 Nov 2007 19:44:37 +0100
To: Apu islam via RT <bug-IO-Socket-SSL [...] rt.cpan.org>
From: Steffen Ullrich <Steffen_Ullrich [...] genua.de>
Download (untitled) / with headers
text/plain 1002b
On Sun, Nov 11, 2007 at 11:52:56PM -0500, Apu islam via RT <bug-IO-Socket-SSL@rt.cpan.org> wrote: Show quoted text
> > Queue: IO-Socket-SSL > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=30600 > > > Ok, here is the code I tried. Couple of the things are missing - namely the security certificates. I have tried with snake oil ca signed certs and it works for a single server mode ( leading me to believe the certificates work). > Others are the I have changed the soap server domain names etc.. > > BTW. I actually know of 3 Steffen Ulrich's myself - leads me to believe this certainly is a very popular German name..
First, could I close the ticket, or is the original problem still there? At the moment we discuss another problem. Then, I have currently no access to a Win32 system, but I've found, that non-blocking on Win32 is silently unsupported so that might be the problem. Could you please try attached developer version 1.12_1 which tries to work around the problem? Regards, Steffen
Download IO-Socket-SSL-1.12_1.tar.gz
application/octet-stream 50.7k

Message body not shown because it is not plain text.

CC: behroozi [...] pls.uni.edu
Subject: Re: [rt.cpan.org #30600] Version conflict with Net::SSLeay
Date: Thu, 15 Nov 2007 11:22:23 -0800 (PST)
To: bug-IO-Socket-SSL [...] rt.cpan.org
From: Apu islam <apu_islam [...] yahoo.com>
Download (untitled) / with headers
text/plain 1.5k
Yes, you can close the original ticket. I had put the debug code and it's giving me the right place to look. I am going to try your debug version and inform you how it worked. Thanks greatly. ------------------------------ Apu Islam ( E Pluribus Unum) Show quoted text
----- Original Message ---- From: Steffen Ullrich via RT <bug-IO-Socket-SSL@rt.cpan.org> To: apu_islam@yahoo.com Cc: behroozi@www.pls.uni.edu Sent: Thursday, November 15, 2007 12:45:55 PM Subject: Re: [rt.cpan.org #30600] Version conflict with Net::SSLeay <URL: http://rt.cpan.org/Ticket/Display.html?id=30600 > On Sun, Nov 11, 2007 at 11:52:56PM -0500, Apu islam via RT <bug-IO-Socket-SSL@rt.cpan.org> wrote:
> > Queue: IO-Socket-SSL > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=30600 > > > Ok, here is the code I tried. Couple of the things are missing -
namely the security certificates. I have tried with snake oil ca signed certs and it works for a single server mode ( leading me to believe the certificates work).
> Others are the I have changed the soap server domain names etc.. > > BTW. I actually know of 3 Steffen Ulrich's myself - leads me to
believe this certainly is a very popular German name.. First, could I close the ticket, or is the original problem still there? At the moment we discuss another problem. Then, I have currently no access to a Win32 system, but I've found, that non-blocking on Win32 is silently unsupported so that might be the problem. Could you please try attached developer version 1.12_1 which tries to work around the problem? Regards, Steffen
Download (untitled) / with headers
text/plain 268b
On Do. 15. Nov. 2007, 14:23:10, apu_islam@yahoo.com wrote: Show quoted text
> Yes, you can close the original ticket. I had put the debug code and > it's giving me the right place to look.
original ticket (Version conflict) closed. Other issues will be handled outside of this ticket.
Subject: Re: [rt.cpan.org #30600] Version conflict with Net::SSLeay
Date: Sun, 25 Nov 2007 14:19:40 -0800 (PST)
To: bug-IO-Socket-SSL [...] rt.cpan.org
From: Apu islam <apu_islam [...] yahoo.com>
Download (untitled) / with headers
text/plain 635b
Hello Steffen, I have tried with your module but the same result on forking on windows. accept() does not seem to like those forked calls. :-( -Apu --- Steffen Ullrich via RT <bug-IO-Socket-SSL@rt.cpan.org> wrote: Show quoted text
> > <URL: > http://rt.cpan.org/Ticket/Display.html?id=30600 > > > On Do. 15. Nov. 2007, 14:23:10, apu_islam@yahoo.com > wrote:
> > Yes, you can close the original ticket. I had put
> the debug code and
> > it's giving me the right place to look.
> > original ticket (Version conflict) closed. > Other issues will be handled outside of this ticket. >
------------------------------ Apu Islam ( E Pluribus Unum)
Download (untitled) / with headers
text/plain 172b
this bug is closed. Please don't respond to this bug with unrelated things, because this would reopen the bug. The other issue will be handled outside of this bug. Steffen


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.