This queue is for tickets about the HTML-Parser CPAN distribution.

Report information
The Basics
Id:
30361
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
CHORNY [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Wishlist
Broken in:
3.56
Fixed in:
(no value)



Subject: [PATCH] compatibility with older perls
XSLoader is now on CPAN, it works on perl 5.4. Also adds license for META.yml & better skip of unicode.t. Tested patch on 5.5. Attached distribution that requires only version change and 'Changes'. -- Alexandr Ciornii, http://chorny.net
Subject: HTML-Parser-3.56.tar.gz

Message body not shown because it is not plain text.

Subject: Makefile.PL.patch
--- Makefile.PL.dist Fri Jan 12 12:29:45 2007 +++ Makefile.PL Tue Oct 30 10:51:23 2007 @@ -1,4 +1,3 @@ -require 5.006; use strict; use ExtUtils::MakeMaker; @@ -8,8 +7,11 @@ H => [ "hparser.h", "hctype.h", "tokenpos.h", "pfunc.h", "hparser.c", "util.c", ], + ($ExtUtils::MakeMaker::VERSION gt '6.30'? + ('LICENSE' => 'perl', ) : ()), PREREQ_PM => { 'HTML::Tagset' => 3, + 'XSLoader' => 0, 'Test::More' => 0, # only needed to run 'make test' }, DEFINE => "-DMARKED_SECTION",
Subject: unicode.t.patch
--- unicode.t.dist Tue Mar 21 19:04:57 2006 +++ unicode.t Tue Oct 30 12:08:29 2007 @@ -2,10 +2,12 @@ use strict; use HTML::Parser; -use Test::More tests => 103; +use Test::More; +BEGIN { + plan skip_all => "This perl does not support Unicode" if $] < 5.008; +} -SKIP: { -skip "This perl does not support Unicode", 103 if $] < 5.008; +plan tests => 103; my @warn; $SIG{__WARN__} = sub { @@ -180,4 +182,3 @@ ok(HTML::Entities::_probably_utf8_chunk("f\xE2\x99\xA5o\xE2\x99")); ok(!HTML::Entities::_probably_utf8_chunk("f\xE2")); ok(!HTML::Entities::_probably_utf8_chunk("f\xE2\x99")); -}
Thanks! Applied.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.