Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Storable CPAN distribution.

Report information
The Basics
Id:
30201
Status:
new
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
SREZIC [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Normal
Broken in:
(no value)
Fixed in:
(no value)

Attachments


Subject: Compile under 5.00404
The attached patch seems to be necessary to compile Storable under 5.00404. There are still some test failures, but at least it compiles. Regards, Slaven
Subject: Storable-newCONSTSUB.patch
--- /usr/local/src/CPAN/build/Storable-2.16-7ByQf1/Storable.xs Wed Mar 21 03:16:24 2007 +++ Storable.xs Tue Oct 23 00:20:28 2007 @@ -20,6 +20,7 @@ #if !defined(PERL_VERSION) || PERL_VERSION < 8 #define NEED_load_module #define NEED_vload_module +#define NEED_newCONSTSUB #include "ppport.h" /* handle old perls */ #endif


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.