Skip Menu |
 

This queue is for tickets about the DBD-SQLite CPAN distribution.

Report information
The Basics
Id: 30167
Status: resolved
Priority: 0/
Queue: DBD-SQLite

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.14
Fixed in: 1.19_01

Attachments


Subject: Specify configuration depenencies with "configure_requires"
Download (untitled) / with headers
text/plain 332b
DBD::SQLite needs DBI::DBD to create Makefile from Makefile.PL. To help tools like CPAN.pm it is now possible to specify configure_requires in the META.yml, so DBI would be built before calling Makefile.PL from DBD::SQLite. See also: http://module-build.sourceforge.net/META-spec-blead.html#configure_requires Regards, Slaven
Download (untitled) / with headers
text/plain 712b
On Sun Oct 21 03:53:44 2007, SREZIC wrote: Show quoted text
> DBD::SQLite needs DBI::DBD to create Makefile from Makefile.PL. To help > tools like CPAN.pm it is now possible to specify configure_requires in > the META.yml, so DBI would be built before calling Makefile.PL from > DBD::SQLite. > > See also: >
http://module-build.sourceforge.net/META-spec-blead.html#configure_requires Show quoted text
>
Attached is a patch which adds the missing configure_requires to META.yml. Note that the undocumented EXTRA_META MakeMaker key is used, which works, but will probably be replaced in future MakeMaker versions by something else. But as this key is only used when creating distributions, I think it is rather safe to use. Regards, Slaven
# # # To apply this patch: # STEP 1: Chdir to the source directory. # STEP 2: Run the 'applypatch' program with this patch file as input. # # If you do not have 'applypatch', it is part of the 'makepatch' package # that you can fetch from the Comprehensive Perl Archive Network: # http://www.perl.com/CPAN/authors/Johan_Vromans/makepatch-x.y.tar.gz # In the above URL, 'x' should be 2 or higher. # # To apply this patch without the use of 'applypatch': # STEP 1: Chdir to the source directory. # STEP 2: Run the 'patch' program with this file as input. # #### End of Preamble #### #### Patch data follows #### diff -up 'build/DBD-SQLite-1.14-Sqm1Wu/Makefile.PL' 'new.build/DBD-SQLite-1.14/Makefile.PL' Index: ./Makefile.PL --- ./Makefile.PL Tue Aug 28 21:57:09 2007 +++ ./Makefile.PL Sat Nov 24 22:33:19 2007 @@ -133,6 +133,10 @@ WriteMakefile( 'clean' => { FILES => 'SQLite.xsi config.h tv.log output' }, 'PL_FILES' => {}, 'EXE_FILES' => [], + 'EXTRA_META' => <<'EOF', +configure_requires: + DBI: 1.21 +EOF ); package MY; #### End of Patch data #### #### ApplyPatch data follows #### # Data version : 1.0 # Date generated : Sat Nov 24 22:34:22 2007 # Generated by : makepatch 2.03 # Recurse directories : Yes # Excluded files : (\A|/).*\~\Z # (\A|/).*\.a\Z # (\A|/).*\.bak\Z # (\A|/).*\.BAK\Z # (\A|/).*\.elc\Z # (\A|/).*\.exe\Z # (\A|/).*\.gz\Z # (\A|/).*\.ln\Z # (\A|/).*\.o\Z # (\A|/).*\.obj\Z # (\A|/).*\.olb\Z # (\A|/).*\.old\Z # (\A|/).*\.orig\Z # (\A|/).*\.rej\Z # (\A|/).*\.so\Z # (\A|/).*\.Z\Z # (\A|/)\.del\-.*\Z # (\A|/)\.make\.state\Z # (\A|/)\.nse_depinfo\Z # (\A|/)core\Z # (\A|/)tags\Z # (\A|/)TAGS\Z # p 'Makefile.PL' 5004 1195939999 0100644 #### End of ApplyPatch data #### #### End of Patch kit [created: Sat Nov 24 22:34:22 2007] #### #### Patch checksum: 49 1707 34371 #### #### Checksum: 67 2331 20365 ####
Download (untitled) / with headers
text/plain 937b
On Sat Nov 24 16:37:54 2007, SREZIC wrote: Show quoted text
> On Sun Oct 21 03:53:44 2007, SREZIC wrote:
> > DBD::SQLite needs DBI::DBD to create Makefile from Makefile.PL. To help > > tools like CPAN.pm it is now possible to specify configure_requires in > > the META.yml, so DBI would be built before calling Makefile.PL from > > DBD::SQLite. > > > > See also: > >
>
http://module-build.sourceforge.net/META-spec-blead.html#configure_requires Show quoted text
> >
> > Attached is a patch which adds the missing configure_requires to > META.yml. Note that the undocumented EXTRA_META MakeMaker key is used, > which works, but will probably be replaced in future MakeMaker versions > by something else. But as this key is only used when creating > distributions, I think it is rather safe to use. > > Regards, > Slaven
Note that the undocumented EXTRA_META key was removed in recent MakeMaker versions, and META_ADD has to be used instead. Regards, Slaven
fixed in 1.19_01 -- Alexandr Ciornii, http://chorny.net
Resolved


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.