Skip Menu |
 

This queue is for tickets about the XML-Twig CPAN distribution.

Report information
The Basics
Id: 29727
Status: resolved
Priority: 0/
Queue: XML-Twig

People
Owner: Nobody in particular
Requestors: ANDK [...] cpan.org
Cc: RCLAMP [...] cpan.org
AdminCc:

Bug Information
Severity: Important
Broken in: 3.29
Fixed in:
  • 3.30
  • 3.31
  • 3.32



CC: RCLAMP [...] cpan.org
Subject: Tests started failing recently when Test::Pod::Coverage installed
Download (untitled) / with headers
text/plain 660b
After I have tested and installed XML::Twig 440 times successfully with many flavours of bleadperl, I notice that we recently changed color to red. Failed Test Stat Wstat Total Fail List of Failed ------------------------------------------------------------------------------- t/pod_coverage.t 1 256 1 1 1 Failed 1/88 test scripts. 1/4068 subtests failed. Files=88, Tests=4068, 77 wallclock secs (31.90 cusr + 2.33 csys = 34.23 CPU) Failed 1/88 test programs. 1/4068 subtests failed. As it started to fail around mid September when Pod-Coverage 0.19 was released, I tried downgrading to Pod-Coverage 0.18 and indeed it fixed the problem.
Subject: Re: [rt.cpan.org #29727] Tests started failing recently when Test::Pod::Coverage installed
Date: Wed, 3 Oct 2007 05:50:43 +0200
To: bug-XML-Twig [...] rt.cpan.org
From: "Michel Rodriguez" <xmltwig [...] gmail.com>
Download (untitled) / with headers
text/plain 1.1k
On 10/2/07, Andreas Koenig via RT <bug-XML-Twig@rt.cpan.org> wrote: Show quoted text
> After I have tested and installed XML::Twig 440 times successfully with > many flavours of bleadperl, I notice that we recently changed color to red. > > Failed Test Stat Wstat Total Fail List of Failed > ------------------------------------------------------------------------------- > t/pod_coverage.t 1 256 1 1 1 > Failed 1/88 test scripts. 1/4068 subtests failed. > Files=88, Tests=4068, 77 wallclock secs (31.90 cusr + 2.33 csys = 34.23 > CPU) > Failed 1/88 test programs. 1/4068 subtests failed. > > > As it started to fail around mid September when Pod-Coverage 0.19 was > released, I tried downgrading to Pod-Coverage 0.18 and indeed it fixed > the problem.
Thanks Andrea, I noticed that too. Pod::Coverage doesn't like this line: *isa = \&UNIVERSAL::isa; It complains that I don't document isa. I changed it to the more correct use UNIVERSAL qw(isa); and the test now passes. I'll release a new version this week probably. Thanks a lot for not only running the tests but also taking the time to figure out what was wrong. -- mirod


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.