Skip Menu |
 

This queue is for tickets about the Alien-wxWidgets CPAN distribution.

Report information
The Basics
Id: 29222
Status: open
Priority: 0/
Queue: Alien-wxWidgets

People
Owner: Nobody in particular
Requestors:
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.32
Fixed in: (no value)



Subject: link_library problems on Solaris 10
Download (untitled) / with headers
text/plain 886b
The link_libraries vale in Alien/wxWidgets/Config/gtk2_2_8_4_gcc_3_4.pm is missing the gcc required -R <path> value for Solaris. After installation, if I make the following change, Wx test run, without it they fail with ldd failures. bash-3.00# diff /.cpan/build/Alien-wxWidgets-0.32/blib/arch/Alien/wxWidgets/Config/gtk2_2_8_4_gcc_3_4.pm /opt/ActivePerl-5.8/lib/site_perl/5.8.7/sun4-solaris-thread-multi/Alien/wxWidgets/Config/gtk2_2_8_4_gcc_3_4.pm 16c16 < 'link_libraries' => ' -L/opt/ActivePerl-5.8/lib/site_perl/5.8.7/sun4-solaris-thread-multi/Alien/wxWidgets/gtk_2_8_4/lib -pthreads -L/usr/openwin/lib', --- Show quoted text
> 'link_libraries' => '
-R/opt/ActivePerl-5.8/lib/site_perl/5.8.7/sun4-solaris-thread-multi/Alien/wxWidgets/gtk_2_8_4/lib -L/opt/ActivePerl-5.8/lib/site_perl/5.8.7/sun4-solaris-thread-multi/Alien/wxWidgets/gtk_2_8_4/lib -pthreads -L/usr/openwin/lib',
Subject: Re: [rt.cpan.org #29222] link_library problems on Solaris 10
Date: Sat, 8 Sep 2007 17:40:32 +0200
To: bug-Alien-wxWidgets [...] rt.cpan.org
From: Mattia Barbon <mattia.barbon [...] libero.it>
Download (untitled) / with headers
text/plain 955b
On Fri, 07 Sep 2007 12:02:12 -0400 "jerry@matilda.com via RT" <bug-Alien-wxWidgets@rt.cpan.org> wrote: Show quoted text
> The link_libraries vale in Alien/wxWidgets/Config/gtk2_2_8_4_gcc_3_4.pm > is missing the gcc required -R <path> value for Solaris.
I am afreaid other compilers would require different flags, in wxWidgets' configure I see both -rpath and -R for Solaris. Show quoted text
> After installation, if I make the following change, Wx test run, without > it they fail with ldd failures. > > bash-3.00# diff > /.cpan/build/Alien-wxWidgets-0.32/blib/arch/Alien/wxWidgets/Config/gtk2_2_8_4_gcc_3_4.pm > /opt/ActivePerl-5.8/lib/site_perl/5.8.7/sun4-solaris-thread-multi/Alien/wxWidgets/Config/gtk2_2_8_4_gcc_3_4.pm > 16c16
This obviously isn't something I can apply; could you provide a patch to Any_wx_config.pm that checks the compiler is GCC and adds the correct -R flags (taking into account the install path will be different for different users)? Thanks! Mattia


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.