Skip Menu |
 

This queue is for tickets about the Scalar-List-Utils CPAN distribution.

Report information
The Basics
Id: 2920
Status: resolved
Priority: 0/
Queue: Scalar-List-Utils

People
Owner: Nobody in particular
Requestors: spurkis [...] epn.nu
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.11
Fixed in: (no value)



Subject: [BUG] $Scalar::Util::VERSION unknown to CPAN
Download (untitled) / with headers
text/plain 550b
Hi, I've experienced minor problems installing Scalar::Util from the cpan shell. It looks to me like CPAN can't figure out what the version number is: Show quoted text
cpan> i /Scalar::Util/
... CPAN_VERSION undef ... INST_VERSION 1.07 And consequently: Show quoted text
cpan> install Scalar::Util
Scalar::Util is up to date. The same is true when you look at: http://search.cpan.org/author/GBARR/Scalar-List-Utils-1.11/ (ie: no version number listed for Scalar::Util) My suggested fix is to hard-code $VERSION as in List::Util. Hope this helps, -Steve
Date: Wed, 9 Jul 2003 09:20:55 -0700
Subject: Re: [cpan #2920] [BUG] $Scalar::Util::VERSION unknown to CPAN
From: Graham Barr <gbarr [...] pobox.com>
To: bug-Scalar-List-Utils [...] rt.cpan.org
RT-Send-Cc:
Download (untitled) / with headers
text/plain 308b
On Wednesday, Jul 9, 2003, at 03:09 US/Pacific, Steve_Purkis via RT wrote: Show quoted text
> > My suggested fix is to hard-code $VERSION as in List::Util.
Then I have to maintain the number in 2 places, thats asking for me to make a mistake. Just tell CPAN to install List::Util as they always come together. Graham.
Date: Wed, 9 Jul 2003 12:41:06 -0700
Subject: Re: [Comment] Re: [cpan #2920] [BUG] $Scalar::Util::VERSION unknown to CPAN
From: Graham Barr <gbarr [...] pobox.com>
To: bug-Scalar-List-Utils [...] rt.cpan.org
RT-Send-Cc:
Download (untitled) / with headers
text/plain 851b
On Wednesday, Jul 9, 2003, at 11:36 US/Pacific, spurkis@epn.nu via RT wrote: Show quoted text
>> Just tell CPAN to install List::Util as they always come together.
> > That's what I ended up doing. But the idea was to spare others the > learning curve... I tracked it down to good ol' MakeMaker - it seems > CPAN.pm uses MM->parse_version. Adding this to Scalar::Util should fix > the problem: > > # make version visible to CPAN: > $VERSION = (require(List::Util), $List::Util::VERSION)[1];
That might work. The Safe compartment used by search.cpan.org may not allow this to work, but I will look into it Show quoted text
> While it shouldn't give users any performance overheads, CPAN machines > might incur a slight overhead as they've got to load List::Util.. And > I don't really know enough to estimate the impact of that. >
The overhead will not be noticed Graham.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.