Skip Menu |
 

This queue is for tickets about the Graph-Easy CPAN distribution.

Report information
The Basics
Id: 28721
Status: open
Priority: 0/
Queue: Graph-Easy

People
Owner: TELS [...] cpan.org
Requestors: berenyi.peter [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Node not connected in layout
Date: Tue, 7 Aug 2007 19:45:54 +0200
To: bug-Graph-Easy [...] rt.cpan.org
From: "Berényi Péter" <berenyi.peter [...] gmail.com>
Download (untitled) / with headers
text/plain 1.5k
Hi, I'm using Graph:Easy v0.56 to create online graphs using SVG output with Perl version 5.8.8 on Windows. I have found an error inthe layout of the following graph: graph { flow: south; } [developers] -> [functionality] [functionality] -> [based_on] [functionality] -> [implemented_in] [functionality] -> [implemented_by] [functionality] -> [input] [functionality] -> [output] [developers] -> [source_file] [source_file] -> [located_in] [developers] -> [functions] [developers] -> [bugs] [developers] -> [actions] [developers] -> [software_has_developers] The node called "output" dos not get connected to the node "functionality" however it should be connected. If I remove one edge around the node "functionality" it gets connected. The code to display the graph is the following: #!c:/Perl/bin/perl.exe use Graph::Easy::Parser; my $gtext = "graph { flow: south; } [developers] -> [functionality] [functionality] -> [based_on] [functionality] -> [implemented_in] [functionality] -> [implemented_by] [functionality] -> [input] [functionality] -> [output] [developers] -> [source_file] [source_file] -> [located_in] [developers] -> [functions] [developers] -> [bugs] [developers] -> [actions] [developers] -> [software_has_developers]"; my $parser = Graph::Easy::Parser->new(); my $graph = $parser->from_text($gtext); print "Content-type: text/xml\n\n"; print $graph->as_svg_file(); Thanks for Your help. Regards Peter Berenyi -- ---------------------------------------------------------------- "Minden túlsó parttal szemben megtalálod az innensőt" Karinthy
Subject: Re: [rt.cpan.org #28721] Node not connected in layout
Date: Tue, 7 Aug 2007 21:17:16 +0200
To: bug-Graph-Easy [...] rt.cpan.org
From: Tels <nospam-abuse [...] bloodgate.com>
Hello, On Tuesday 07 August 2007 19:48:27 Berényi Péter via RT wrote: Show quoted text
> Tue Aug 07 13:48:25 2007: Request 28721 was acted upon. > Transaction: Ticket created by berenyi.peter@gmail.com > Queue: Graph-Easy > Subject: Node not connected in layout > Broken in: (no value) > Severity: (no value) > Owner: Nobody > Requestors: berenyi.peter@gmail.com > Status: new > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=28721 > > > > Hi, > > I'm using Graph:Easy v0.56 to create online graphs using SVG output > with Perl version 5.8.8 on Windows. I have found an error inthe layout > of the following graph: > > graph { flow: south; } [developers] -> [functionality] [functionality] > -> [based_on] [functionality] -> [implemented_in] [functionality] -> > [implemented_by] [functionality] -> [input] [functionality] -> > [output] [developers] -> [source_file] [source_file] -> [located_in] > [developers] -> [functions] [developers] -> [bugs] [developers] -> > [actions] [developers] -> [software_has_developers] > > The node called "output" dos not get connected to the node > "functionality" however it should be connected. If I remove one edge > around the node "functionality" it gets connected.
Running this through graph-easy prints: Layouter could only place 13 nodes/11 edges out of 13/12 - giving up at bin/graph-easy line 100 The reason is the layouter is quite limited and stumbles and cannot complete the layout :/ Sorry about this, I willsee what I can do to teach it a few more tricks in the next version. A workaround is to make the [functionality] node bigger: graph { flow: south; } [ developers ] --> [ functionality ] { size: 2,2; } [ developers ] --> [ source_file ] [ developers ] --> [ actions ] [ developers ] --> [ bugs ] [ developers ] --> [ functions ] [ developers ] --> [ software_has_developers ] [ functionality ] --> [ based_on ] [ functionality ] --> [ implemented_by ] [ functionality ] --> [ implemented_in ] [ functionality ] --> [ input ] [ functionality ] --> [ output ] [ source_file ] --> [ located_in ] The output is still way too tangled, but at least it shows all connections. Detangling gets easier for the layouter if you give it hints to increase nodes even further, like setting size 2,2 on [developers]. Althought the layouter could be really better. Btw, you can use node lists to reduce the text: [ developers ] --> [ functionality ] { size: 2,2; }, [ source_file ], [ actions ], [ bugs ], [ functions ], [ software_has_developers ] [ functionality ] --> [ based_on ], [ implemented_by ], [ implemented_in ], [ input ], [ output ] [ source_file ] --> [ located_in ] All the best, Tels -- Signed on Tue Aug 7 21:11:24 2007 with key 0x93B84C15. View my photo gallery: http://bloodgate.com/photos PGP key on http://bloodgate.com/tels.asc or per email. "But the product unquestionably brings new features and capabilities to solution providers that in turn promise new revenue generation dialogues with end users." -- CRN.com about Windows Vista
Download (untitled)
application/pgp-signature 481b

Message body not shown because it is not plain text.

Subject: Re: [rt.cpan.org #28721] Node not connected in layout
Date: Tue, 7 Aug 2007 21:48:31 +0200
To: bug-Graph-Easy [...] rt.cpan.org
From: "Berényi Péter" <berenyi.peter [...] gmail.com>
Download (untitled) / with headers
text/plain 2.5k
Hello, thanks for the quick answer. Meanwhile I also found a workaround for the problem, by adding ranks to the different nodes. That way the layouter automaticaly increases the size of rank 1 elements (those with the most connections), and I get all nodes connected properly. Anyway, Graph::Easy is great tool. Thanks and best regards Peter 2007/8/7, nospam-abuse@bloodgate.com via RT <bug-Graph-Easy@rt.cpan.org>: Show quoted text
> > Running this through graph-easy prints: > > Layouter could only place 13 nodes/11 edges out of 13/12 - giving up at > bin/graph-easy line 100 > > The reason is the layouter is quite limited and stumbles and cannot complete > the layout :/ Sorry about this, I willsee what I can do to teach it a few > more tricks in the next version. > > A workaround is to make the [functionality] node bigger: > > graph { flow: south; } > > [ developers ] --> [ functionality ] { size: 2,2; } > [ developers ] --> [ source_file ] > [ developers ] --> [ actions ] > [ developers ] --> [ bugs ] > [ developers ] --> [ functions ] > [ developers ] --> [ software_has_developers ] > [ functionality ] --> [ based_on ] > [ functionality ] --> [ implemented_by ] > [ functionality ] --> [ implemented_in ] > [ functionality ] --> [ input ] > [ functionality ] --> [ output ] > [ source_file ] --> [ located_in ] > > The output is still way too tangled, but at least it shows all connections. > Detangling gets easier for the layouter if you give it hints to increase > nodes even further, like setting size 2,2 on [developers]. Althought the > layouter could be really better. > > Btw, you can use node lists to reduce the text: > > [ developers ] --> [ functionality ] { size: 2,2; }, > [ source_file ], [ actions ], [ bugs ], [ functions ], > [ software_has_developers ] > > [ functionality ] --> [ based_on ], [ implemented_by ], > [ implemented_in ], [ input ], [ output ] > > [ source_file ] --> [ located_in ] > > All the best, > > Tels > > -- > Signed on Tue Aug 7 21:11:24 2007 with key 0x93B84C15. > View my photo gallery: http://bloodgate.com/photos > PGP key on http://bloodgate.com/tels.asc or per email. > > "But the product unquestionably brings new features and capabilities to > solution providers that in turn promise new revenue generation dialogues > with end users." > > -- CRN.com about Windows Vista > > >
-- ---------------------------------------------------------------- "Minden túlsó parttal szemben megtalálod az innensőt" Karinthy


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.