Skip Menu |
 

This queue is for tickets about the Mail-SPF CPAN distribution.

Report information
The Basics
Id: 28699
Status: resolved
Priority: 0/
Queue: Mail-SPF

People
Owner: JMEHNLE [...] cpan.org
Requestors: schneecrash+cpan [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: cpan says Mail::SPF/Mail::SPF::Test require updates -- to same version as is installed
Date: Mon, 6 Aug 2007 17:30:51 -0700
To: bug-Mail-SPF [...] rt.cpan.org
From: snowcrash+cpan <schneecrash+cpan [...] gmail.com>
Download (untitled) / with headers
text/plain 1003b
i've perl588+cpan installed on FreeBSD 62p7. i've installed "Mail-SPF" & "Mail-SPF-Test", module_info Mail::SPF Name: Mail::SPF Version: v2.005 Directory: /usr/local/lib/perl5/site_perl/5.8.8 File: /usr/local/lib/perl5/site_perl/5.8.8/Mail/SPF.pm Core module: no module_info Mail::SPF::Test Name: Mail::SPF::Test Version: v1.001 Directory: /usr/local/lib/perl5/site_perl/5.8.8 File: /usr/local/lib/perl5/site_perl/5.8.8/Mail/SPF/Test.pm Core module: no if i check for available upgrades via, Show quoted text
cpan> r
it reports, Package namespace installed latest in CPAN file Mail::SPF v2.005 2.005 JMEHNLE/mail-spf/Mail-SPF-v2.005.tar.gz Mail::SPF::Test v1.001 1.001 JMEHNLE/mail-spf-test/Mail-SPF-Test-v1.001.tar.gz note the version #'s are the same for each package. running Show quoted text
cpan> upgrade Mail::SPF Mail::SPF::Test
simply reinstalls the modules, and the 'available update' status does not change.
Download (untitled) / with headers
text/plain 237b
What version of CPAN.pm are you running, i.e., what does the following say on your machine? $ perl -MCPAN -le 'print(CPAN->VERSION)' Perhaps this is just an instance of http://rt.cpan.org/Ticket/Display.html?id=27240 (a CPAN.pm bug)
Subject: Re: [rt.cpan.org #28699] cpan says Mail::SPF/Mail::SPF::Test require updates -- to same version as is installed
Date: Fri, 21 Sep 2007 12:55:52 -0700
To: bug-Mail-SPF [...] rt.cpan.org
From: snowcrash+cpan <schneecrash+cpan [...] gmail.com>
Download (untitled) / with headers
text/plain 1.4k
hi, Show quoted text
> What version of CPAN.pm are you running, i.e., what does the following > say on your machine? > > $ perl -MCPAN -le 'print(CPAN->VERSION)'
perl -MCPAN -le 'print(CPAN->VERSION)' 1.9102 Show quoted text
> Perhaps this is just an instance of > http://rt.cpan.org/Ticket/Display.html?id=27240 (a CPAN.pm bug)
aha! seems to be ... module_info Mail::SPF Name: Mail::SPF Version: v2.005 Directory: /usr/local/lib/perl5/site_perl/5.8.8 File: /usr/local/lib/perl5/site_perl/5.8.8/Mail/SPF.pm Core module: no module_info Mail::SPF::Test Name: Mail::SPF::Test Version: v1.001 Directory: /usr/local/lib/perl5/site_perl/5.8.8 File: /usr/local/lib/perl5/site_perl/5.8.8/Mail/SPF/Test.pm Core module: no with "cpan", cpan Show quoted text
cpan> r
... Going to write /usr/local/.cpan/Metadata Package namespace installed latest in CPAN file Mail::SPF v2.005 2.005 JMEHNLE/mail-spf/Mail-SPF-v2.005.tar.gz Mail::SPF::Test v1.001 1.001 JMEHNLE/mail-spf-test/Mail-SPF-Test-v1.001.tar.gz Net::DNS::Resolver::Programmable v0.003 0.003 JMEHNLE/net-dns-resolver-programmable/Net-DNS-Resolver-Programmable-v0.003.tar.gz 3 installed modules have a version number of 0 204 installed modules have no parseable version number Show quoted text
cpan>
"your" three CPAN modules seem to "need" updating. but with "cpanp", which I now exclusively use, % cpanp -o [MSG] Checking if source files are up to date ... % no updates required. Hm. So, a CPAN artifact ... thx!
This issue is fixed by CPAN.pm 1.9200.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.