Skip Menu |
 

This queue is for tickets about the Module-Build CPAN distribution.

Report information
The Basics
Id: 2860
Status: resolved
Priority: 0/
Queue: Module-Build

People
Owner: Nobody in particular
Requestors: MARKSTOS [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 0.18_02
Fixed in: (no value)



Subject: install failure: Data::Dumper object version 2.101 does not match $Data::Dumper::VERSION 2.081
Download (untitled) / with headers
text/plain 893b
bash-2.05b# perl Build.PL Data::Dumper object version 2.101 does not match $Data::Dumper::VERSION 2.081 at / usr/libdata/perl/5.00503/DynaLoader.pm line 188. BEGIN failed--compilation aborted at lib/Module/Build/Base.pm line 14. BEGIN failed--compilation aborted at lib/Module/Build/Platform/Unix.pm line 4. BEGIN failed--compilation aborted at (eval 1) line 2. BEGIN failed--compilation aborted at Build.PL line 9. #### Adding Data::Dumper as a prequisite may be a partial solution. On my FreeBSD server, after upgrading there 3 different versions of Data:;Dumper installed, all in "system" library locations. So if there would be a way to make sure tha the Data::Dumper that just got installed is the one being required, that would be great. In my case, that didn't happen automatically. I had to set PERL5LIB in the environment to the right value to get Module::Build to install.
Download (untitled) / with headers
text/plain 821b
[MARKSTOS - Fri Jun 27 16:54:05 2003]: Show quoted text
> > Adding Data::Dumper as a prequisite may be a partial solution.
Data::Dumper is already listed as a prerequisite for Module::Build. Show quoted text
> On my FreeBSD server, > after upgrading there 3 different versions of Data:;Dumper installed, > all in "system" > library locations. So if there would be a way to make sure tha the > Data::Dumper that just > got installed is the one being required, that would be great.
I'm not sure what you mean - Module::Build doesn't load modules any differently than anything else does. If you install Data::Dumper in such a way that a 'use Data::Dumper;' statement doesn't work, then the problem is in the Data::Dumper installation. Module::Build also has no way to determine which installed version of a module is the one you just installed.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.