Skip Menu |
 

This queue is for tickets about the Scalar-List-Utils CPAN distribution.

Report information
The Basics
Id: 28235
Status: resolved
Priority: 0/
Queue: Scalar-List-Utils

People
Owner: Nobody in particular
Requestors: Steffen_Ullrich [...] genua.de
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in:
  • 1.18
  • 1.19
Fixed in: (no value)



Subject: dualvar not available if not build as XS, but this is not documented
Download (untitled) / with headers
text/plain 230b
dualvar and set_prototype are not available if Scalar::Util is not build as XS. This limit is not documented. It also causes modules like IO::Socket::SSL to fail which expect dualvar to be available when Scalar::Util is available.
From: JANW [...] cpan.org
Download (untitled) / with headers
text/plain 132b
This bug still exists in 1.19 and quite a umber of modules fail misteriously with the non-XS version installed, like Compress::Zlib.
Download (untitled) / with headers
text/plain 441b
On Sun Jul 15 15:48:42 2007, SULLR wrote: Show quoted text
> dualvar and set_prototype are not available if Scalar::Util is not build > as XS. This limit is not documented. It also causes modules like > IO::Socket::SSL to fail which expect dualvar to be available when > Scalar::Util is available.
To make matters worse, the code that reports the failure is broken. sub export_fail depends on grep setting $1, but that does not happen -- on 5.8.8 at least.
added a note with the list; added a test to assert that the errors are raised (it passes) -- rjbs


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.