Skip Menu |
 

This queue is for tickets about the PAR-Packer CPAN distribution.

Report information
The Basics
Id: 28217
Status: rejected
Priority: 0/
Queue: PAR-Packer

People
Owner: Nobody in particular
Requestors: soso [...] kol.co.nz
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: PAR-Packer-0.975 make failed
Date: Sun, 15 Jul 2007 16:59:03 +1200
To: bug-par [...] rt.cpan.org
From: Sean <soso [...] kol.co.nz>
Download (untitled) / with headers
text/plain 1.8k
Hi PAR-Packer-0.975 make failure report: The Makefile went ok after manually installing dependencies and reports all dependencies as "loaded". But make fails, the tail end of the output verbatim as follows: .... /usr/local/lib/perl5/perl5.8.7 parlsig.pl ./static ./par 1 30000 ./static -I"/F/www/go/perl/win-perl/PAR-Packer-0.975/inc" -I"/usr/local/lib/perl5/site_perl/5.8.7/i686-linux-thread-multi" -I"/usr/local/lib/perl5/site_perl/5.8.7/i686-linux-thread-multi" -I"/usr/local/lib/perl5/site_perl/5.8.7" -I"/G/go/perl" -I"/G/go/perl/BDB" -I"/G/go/perl/DB" -I"/G/go/perl/Grid" -I"/G/go/perl/Map" -I"/G/go/perl/Mkt" -I"/X/go/rpc" -I"/G/go/perl/Subs" -I"/G/go/perl/Web" -I"/usr/local/lib/perl5/site_perl/5.8.7/i686-linux-thread-multi" -I"/usr/local/lib/perl5/site_perl/5.8.7" -I"/usr/local/lib/perl5/5.8.7/i686-linux-thread-multi" -I"/usr/local/lib/perl5/5.8.7" -I"/usr/local/lib/perl5/site_perl/5.8.7/i686-linux-thread-multi" -I"/usr/local/lib/perl5/site_perl/5.8.7" -I"/usr/local/lib/perl5/site_perl" -I"/usr/lib/perl5/site-perl/5.8.0-Dlocincpth=/usr/include/db4" -I"/F/www/go/perl/win-perl/PAR-Packer-0.975" -I"." -I../myldr/.. -I../blib/lib -q -B -O../script/parl is only avaliable with the XS version at /usr/local/lib/perl5/site_perl/5.8.7/Compress/Zlib.pm line 9 BEGIN failed--compilation aborted at /usr/local/lib/perl5/site_perl/5.8.7/Compress/Zlib.pm line 9. Compilation failed in require at /usr/local/lib/perl5/site_perl/5.8.7/Archive/Zip.pm line 24. BEGIN failed--compilation aborted at /usr/local/lib/perl5/site_perl/5.8.7/Archive/Zip.pm line 24. Compilation failed in require at -e line 406. make[1]: *** [../script/parl] Error 255 make[1]: Leaving directory `/F/www/go/perl/win-perl/PAR-Packer-0.975/myldr' make: *** [subdirs] Error 2 .... end The failed "require" appears to be "use Compress::Zlib" which seems to be installed? Any help appreciated Sean Daly
Download (untitled) / with headers
text/plain 733b
This is a valid bug report and the problem has been observed quite a few times already, but the ticket is a duplicate of https://rt.cpan.org/Ticket/Display.html?id=24192 so I'm rejecting it to keep the clutter in the request tracker down. For more information, please refer to the aforementioned bug report, search the par@perl.org mailing list archives, or refer to par.perl.org (main page and FAQ). Basically, people seem to be able to circumvent this issue by downgrading Compress::Zlib to pre-2.0. I'm not suggesting you do this, though - if you find the real issue, that would be very much appreciated. I'm currently at a loss as to what causes this problem but can't reproduce it on any of my machines. Best regards, Steffen
Subject: Re: [rt.cpan.org #28217] PAR-Packer-0.975 make failed
Date: Mon, 16 Jul 2007 16:54:30 +1200
To: bug-PAR [...] rt.cpan.org
From: Sean <soso [...] kol.co.nz>
Download (untitled) / with headers
text/plain 1.1k
Hi Steffen Many thanks for the prompt reply. Following that lead I downgraded to Compress::Zlib v1.42 and pp 'make' then succeeded. Sorry, I dont know why, but just thought you might like to know what failed and worked on yet another platform/archictecture. cheers Sean Steffen Müller via RT wrote: Show quoted text
><URL: http://rt.cpan.org/Ticket/Display.html?id=28217 > > >This is a valid bug report and the problem has been observed quite a few >times already, but the ticket is a duplicate of >https://rt.cpan.org/Ticket/Display.html?id=24192 so I'm rejecting it to >keep the clutter in the request tracker down. > >For more information, please refer to the aforementioned bug report, >search the par@perl.org mailing list archives, or refer to par.perl.org >(main page and FAQ). > >Basically, people seem to be able to circumvent this issue by >downgrading Compress::Zlib to pre-2.0. I'm not suggesting you do this, >though - if you find the real issue, that would be very much >appreciated. I'm currently at a loss as to what causes this problem but >can't reproduce it on any of my machines. > >Best regards, >Steffen > > > > >


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.